[qubes-users] "Upgrading" by installing

Hi !

So eventually I decided to upgrade my Qubes OS installation by backup, install, then restore.
Unfortunately I'm stuck, and here is my negative experience:
First when using a custom disk layout, i.e.: reuse VG and LV from the current installation, I noticed that I van only assign swap if I select to reformat it. Then it's selected automatically; otherwise it's ignored.
Next it's recommended to reformat the root snd boot filesystems, but noting got the LVs. So ehen trying to install the debian-11 template it failed, template installation was aborted, snd I found to way to resume or restart. See attachment. So I restarted everything, also deleting the LVs for the VMs (which is not easy from the installation environment).
When installation had finished eventually, I tried to restore my VMs, but I'm offered just the basic net and firewall VMs. So I wonder how to do that.
Also I wondered why there is no "import VM" function when the LVs for the VM are still (already) there. I didn't delete the LVs of one of my VMs.

So in summary the installer snd the documentation should be improved.

Regards,
Ulrich
P.S.: Typed on my mobile, so there are probably several typing errors I did not detect.

Hi!

I could really need some help on how to restore my v4.0 backups into v4.1.1 ...

Regards,
Ulrich

I don't really know anything about custom disk layouts, but have you tried restoring by following these instructions?

If so, where exactly did you encounter a problem (i.e., which step)?

Hi!

As it turned out I needed just an extra boot. At least when having mounted the backup volume in Dom0 manually I was able to restore when I couldn't before.
Another confusing thing is that when leaving the first screen nothing seems zo happen, but I noticed the CPU fan spinning up for a few seconds until the next screen appears. Maybe add some progress indicator...

Regards
Ulrich