[qubes-users] [R2B2] Unable to choose sound source (mic)

I attached USB cam (Logitech C920) and trying to setup sound in AppVM.

In Dom0 there is kmix, and Phonon - KDE Control Module.
This Phonon doesn’t save my choice in “Audio Hardware Setup” panel.
When I close it with “ok” button, next time it chooses wrond input source…

I don’t know what is the exact reason, but sound recording doesn’t work in AppVM.

I don’t see sound neither in “sound” application, nor in Skype “Echo test”

How to setup this?

kmix, and Phonon

also i tried pavucontrol in Dom0 from command line, it doesn’t help either.

And I want video too, not just audio. But the command in Qubes Manager says only about audio…

I have the same problem with Phonon in dom0. Changes on the Audio
Hardware Setup tab are never saved.

Here's what I've found works:

1. Click the "Audio Hardware Setup" tab.
2. Under "Device Configuartion," select the correct microphone next to
"Sound Device."
3. Click "Apply." (Do not click "OK." Do not close the window. Leave it
4. If your AppVM was already running, you may have to restart it.
5. Before opening any programs in your AppVM, use the Qubes VM Manager
to attach your microphone to the AppVM.
6. Start Skype (or whichever program you want to use), and it should
work. If it doesn't, try changing the recording device in Skype's settings.

I can confirm that this works with a regular (non-USB) microphone. (YMMV
with a USB microhpone.)