[qubes-users] Problems with debian-11 after VM update attempt

Hi!

I have a problem 8-(

After using Qubes OS after a longer break, I tried to install all updates. That worked for all template VMs except debian-11. Even when re-trying after all the rest was updated and the system rebooted, it won't work.

Even worse I can start a debian-11-based app VM, but I cannot launch any program there. Even "qvm-run debian-11 gnome-terminal" fails.

I have saved the lengthy protocol of the first attempt, however (attached).

It seems the problem was:

Unpacking thunderbird (1:91.12.0-1~deb11u1) over (1:91.8.0-1~deb11u1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-GfbHjN/38-thunderbird_1%3a91.12.0-1~deb11u1_amd64.deb (--unpack):
cannot copy extracted data for './usr/share/thunderbird/omni.ja' to '/usr/share/thunderbird/omni.ja.dpkg-new': failed to write (No space left on device)
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

Note: It's not pool00 that is full. How can I recover from this?

(I'm still at Qubes OS 4.0. I wanted to install the last updates, then backup, then try upgrading to 4.1)

Regards,

Ulrich

debian11.log (58 KB)

You don’t actually need to install the latest updates first, FYI. I
suggest just upgrading.

This particular problem means that your debian-11 template’s privage
volume is full. Growing it via the GUI should fix it.
- --
Sincerely,
Demi Marie Obenour (she/her/hers)
Invisible Things Lab

The system volume of debian-11 is full? It might be possible to revert the
changes to the template if there's an earlier snapshot of it.

Otherwise, you'll need to recover things manually. You can access the vm's
console with xl console. You'll likely need to make some space first
(perhaps by deleting something you can easily recreate). As soon as the
template works almost normally, I'd try to enlarge system volume and then
reinstall all packages that were part of the failing upgrade.

I went the way via updating to 4.1.1, causing a downtime for a few weeks 8-( I'm only using Qubes OS occasionally, so I did most work using other OSes...

Ulrich