[qubes-users] large files can't open in DispVM

Hi, when I try to open a large video file of 1.6GB into a DispVM I get the next error message:

write: No space left on device
write: Connection reset by peer
qopen-in-vm: Fatal error: send file to dispVM (error type: Connection reset by peer)

The command I use is:

qvm-run-vm ‘@dispvm’ video.mkv

If I use the same command with a pdf file it works.

I can see a terminal for a moment and then disappear.

Could you confirm me if there is a limit of size of the file that can be opened into a DispVM?.

thanks you.

Yes, it's whatever size you gave to the private volume of the DVM Template.

So let's say your Template is called 'fedora-32-dvm', then open it's settings in the Qube Manager. It is like set to 2048 MB. This should be enough but depending on what modifications you have done to the template the free space in the private volume could be less than 1.6 GB

Easy way to check:

qvm-run fedora-32-dvm xterm

then in the xterm:

df -h

... you will see how much is free and how much is used. Look for /rw

Then shut it down and increase the private size in the settings. Or just set it to 20480 anyway. :slight_smile: If it's not used it won't take space on your hard disk and since the result is disposable anyway it's no concern.


1 Like

Hi Sven and thanks for your response.

I added more space to private volume. Now I have 10GB, I think it is enought to open a video file.
In other chat a person tell me that maybe the problem is that the process that open the file to DVM try to copy into /temp folder in system storage, maybe thats is the problem.

I opened a terminal in a DVM and copied the video file with qvm-copy-to-vm command, then I run VLC in DVM to open the video file and it worked.

Thanks Sven