[qubes-users] Installing qubes-tunnel on fedora-32-minimal?

Firstly, I was able to get the user contrib qubes tunnel going on a fedora-32-minmal template and it was great! (great meaning so much easier than the more manual methods; though its still not clear to me if it includes a kill switch)

The problem is fed31 has reached EOL so I wanted to install it on a fed32 template so I started with (actually I installed it earlier but wanted to show that it is indeed installed):

bash-5.0# sudo dnf install qubes-repo-contrib
Last metadata expiration check: 0:45:12 ago on Wed Dec 16 11:23:25 2020.
Package qubes-repo-contrib-4.0.7-1.fc32.noarch is already installed.
Dependencies resolved.
Nothing to do.

Then I tried to install the qubes-tunnel:

bash-5.0# sudo dnf install qubes-tunnel
Last metadata expiration check: 0:45:27 ago on Wed Dec 16 11:23:25 2020.
No match for argument: qubes-tunnel
Error: Unable to find a match: qubes-tunnel


I also tried to install qubes-tunnel on the proxyvm for sh*t and giggles but that didnt work either (same error). I looked in the /user/lib/qubes dir and qubes-tunnel wasnt there which explains why I get the error:

bash-5.0# sudo /usr/lib/qubes/qtunnel-setup --config
sudo: /usr/lib/qubes/qtunnel-setup: command not found

when i try to run it.


Thanks, that worked however I run into another problem in that I cant seem to get vpns to work on anything except fed31minimal.
I have tried on centos minimal, debian minimal, fed31 minimal so I am assuming I am doing something wrong, but I dont know what as I AFAIK am doing the same thing i did with fed31.

I start with
sudo dnf install qubes-repo-contrib && sudo dnf update && sudo dnf upgrade

then sudo dnf install qubes-tunnel

Intially I think I was just doing that and not installing anything else but in trying to figure things out I started installing packages that the minimal docs page says are needed for NetVM and VPN qube (things like openvpn and qubes-core-agent-networking qubes-core-agent-network-manager NetworkManager-wifi network-manager-applet wireless-tools notification-daemon gnome-keyring polkit and sakura, a term i can paste into)

The above now seems to work ok, but then I create an appvm - vpnfed32, select the template (centos/deb/fed32 minimals) then check the "provides network" then go to the Services tab and add qubes-tunnel-openvpn then click ok.

Then I make sure the template and new appvm are closed, then start up the vpnvm from dom0:

qvm-run -u root vpnfed32 sakura &

and run

/usr/lib/qubes/qtunnel-setup --config

then enter my vpn provider (PIA) username then password

then copy one of the pia .ovpn profiles to


then shutdown the vpn vm, then open the settings for another appvm set vpnfed32 as the networking vm to vpnfed32 and then try to start the AppVM (that I just set to use vpnfed32) up but nada, no connection to the internet at all.

Is there something above that is incorrect? Or maybe a log I could post?

Thank you in advance