Qubes update kernel in order to install librem drivers

I’m trying to install the librem 14 drivers for Qubes but I’m having an issue with the kernel source in dom0 found at /usr/src/kernels/5.4.175-1.fc25.qubes.x86_64 being different than the currently running kernel returned by uname -r which is 5.4.156-1.fc25.qubes.x86_64. This is causing an issue where when running sudo dkms build librem_ec_acpi/1.0 fails because the correct symlinks are not created due this discrepancy in versioning.

I’ve tried installing a new kernel with sudo qubes-dom0-update kernel but this simply states that I’m reinstalling and nothing changes.

My course of action is currently to synchronize the kernel source and the running kernel. But I am not sure how to do this, do you have any suggestion?

I might also change the librem driver symlinks to the correct source.


$ sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest

and recreating grub helps?

Hi, thank you for the suggestion.
I installed the latest kernel and it is correctly showing that in uname -r however in /usr/src/kernels/ I’m still only seeing the 5.4.175 kernel source code.

And this?

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-devel

This outputs that

Package kernel-devel-1000:5.4.175-1.fc25.qubes.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
No packages downloaded

for some reason the devel kernel is the one I already have. This is different from uname -r which outputs 5.16.11-1.fc25.qubes.x86_64

I’ve tried to get this working again.
I’m now trying to figure out how to downgrade my kernel to 5.4.175 by first downloading it:
sudo qubes-dom0-update kernel-1000:5.4.175-1.fc25.qubes.x86_64 and then sudo dnf downgrade kernel-1000:5.4.175-1.fc25.qubes.x86_64 but this last command returns Package kernel of lowest version already installed, cannot downgrade it. Error: Nothing to do..

uname -r returns 5.16.11-1.fc25.qubes.x86_64 which is downloaded as kernel-latest from the testing repo.

How do I correct downgrade my kernel to 5.4.175?

Bump :slight_smile: