Qubes Update: Error "...qubes-vm-connector..."

When updating Qubes with the “Qubes Updater” I get the following error for all templates.

Updating <TEMPLATE>

    Error on updating <TEMPLATE>: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=whonix-ws-15', '--show-output', 'state.sls', 'update.qubes-vm']' returned non-zero exit status 20
              Failed to return clean data
              Traceback (most recent call last):
                File "/usr/lib/qubes-vm-connector/ssh-wrapper/ssh", line 101, in <module>
                File "/usr/lib/qubes-vm-connector/ssh-wrapper/ssh", line 94, in main
                  return ssh(args)
                File "/usr/lib/qubes-vm-connector/ssh-wrapper/ssh", line 29, in ssh
                  assert args[1] == '/bin/sh'

How can I fix this?

Update manually.

1 Like

I have the same issue and updated all template vms manually.
Then on new updates the same error still exists, i also updated then with current-testing, now i still get the info of new updated but when i try to update i still get the same error as listed above…

I think this is now on the regular updates. So if you update dom0 it should be fixed.

But if after that, it still continues, feel free to discuss it.