Qubes OS installation doesn't work, no boot menu entry

Hellow there,
After the Qubes installation, when i press restart (after the first loading bar is finished) it just boots into Windows. There is no error message or something.
Does anybody knows what do?
I’m desperate :confused:

Check boot order in BIOS and try to change it so Qubes OS boot entry will be before Windows boot entry.


You say boots into Windows, You mean M$ Windows?

I can understand the need to have M$ Windows. I say M$ Windows does not play well with others. Plus, Qubes, to be secure, needs to be the only OS on drive, else other OS’s might corrupt what Qubes is trying to accomplish.

Still, some folks, only intending to learn a bit about Qubes OS before adopting it, sometimes are willing to accept a security compromise, to experience using Qubes.

Not sure which you are? If you need to run a high security system, immediately. As the documentation on the Qube OS site. Documentation | Qubes OS

Qubes wants to installed as the only OS, and is installed bare metal, immediately on top of the hardware.

Best for you to tell us to get guidance:

Which is your goal? If you are in a place where you need highest security possible. you need to use Qubes only on computer.
What exactly is computer? Manufacturer, Make, Model, RAM, Processor, graphics? Have you verified if Virtualization, Iommu, or the equal with AMD is enabled in BIOS/EFI?

What is the UEFI setting?

Drive, or Drives? Some have had problems with having more than one drive on computer. Sometimes not.

Are you experienced in Linux? Helps us, on board, to know how to craft answers. to your experience/knowledge level.

How did you partition drive?

I would suspect - well, it is not always directly easy to create the USB to install from?

Some folks just hit the right formula for that, first time out. Some methods to create a bootable install USB that previously worked, sometimes don’t.

If you are desperate to communicate with someone about something. Look at Tails OS, and its documentation. Smaller, Live USB, anonymous.

Qubes is only anonymous with some efforts on the part of the user (called Operational Security, Op-Sec). Else it might be said, properly implemented to block malware, lessen tracking. Some other things some others (more experienced, more knowledgeable than me) might add to that sentence.


1 Like

The thing is that there is no boot entry, i installed Qubes on a seperate SSD, wiped it before. but there is only the windows entry, the USB stick and of course a lot of “options” but none of them are the SSD

Hellow Catacombs,
Thank you very much for the long answer.

I didnt specify the Question enough, thats my mistake. I installed Qubes to a fresh Drive which is not the Drive windows is installed on. My goal here is to normally use windows, when i use the PC for fun. But when i want to stay secure and anonymous, i switch to Qubes.

Im not very expierinced in linux or any other OS than windows.

I already tried to install Qubes via a USB stick to a differnt, external drive (Drive 1). Also enabled virutalization etc. and booted into it. But after that i never was able to boot into it again. (already created a topic in this forum about that Problem) but the answer and solution was wayy to complicated to execute for me.

The Problem i had problably was, if understood correctly by me, because of the external drive. So because i couldnt solve it, i just used another Drive (Drive 2) this time. But now, after hitting Reboot system, when the installation bar is finished, i just boots into windows and no boot entry is created at all.

Neither drive 1 or 2 is the drive windows is installed on.
i wiped out everthing else that was on the drives.
also when installing Qubes i let the installer create all mounting points for me

i hope you can understand my problem a bit better now.
Thanks for your time very much :slight_smile:

back up Windows drive. I recommend a clone to an external drive.
Back up Windows drive to different external drive.
I should a third drive. but, no one but me would do that.

Use a large USB stick to put all your Windows Data onto it.
EDIT: Put all your passwords on an alternate USB stick as well. Funny how hard it remember those easy to remember passwords are when you need them.

That because things just seem to happen.

Look in BIOS/EFI find, “Secure Boot” click on that hopefully another option to allow you install in Legacy Mode. however, you might need to switch this back to choose UEFI, and turn 'Secure Boot" on to start Windows.

Apparatus is more clear than me. So I think read Apparatus notes. He may have more suggestions to follow.

Note that malware on the Windows installation, will be able to change the kernel/initial filesystem of Qubes OS, if the drive is connected while Windows is running – so it can compromise your security … :-/

A quick test, could be to do the following:

I assume you have the installation stick around still … so could you try:

  • Connect the USB installation stick to the computer
  • Select the Installation stick as the boot medium
  • When you see the “Install Qubes OS R…”/“Test media and …”/“Troubleshooting - …” menu, hit c to get a grub> prompt
  • Type configfile (hd0,gpt1)/EFI/qubes/grub and hit the Tab key on your keyboard – did it complete the line to: grub.cfg?
    – if so, hit enter … if no, try with: configfile (hd1,gpt1)/EFI/qubes/grub and hit Tab
    and report/share the result?

(from a sub-post from the link that @apparatus shared)

Since you have multiple drives, it might have to also try with (hd2,gpt1) or (hd3,gpt1)