Qubes OS 4.1-rc1 has been released!

This is great. But does anyone know what is different from this latest .iso versus the 4.1-rc1 iso that would’ve been available towards the end of August? I ask because that version was not able load the installer on an x230. Using all install options such as the troubleshooting mode.

it’s not equivalent but, the architecture is same.

qubes-dom0-update --action=search --console --show-output qubes template still only shows fedora-33, is this a typo ?

Yes. Simply do dom0 updates, install latest templates and that would result to be the same.


2 posts were split to a new topic: No Match for argument qubes-dist-upgrade (4.0 → 4.1-RC1)

6 posts were split to a new topic: “Error: no multiboot header found” when installing

Great news!
I take it that the new awesome app menus which we had a survey about are not yet ready for release?

Thanks - that is exactly what I wanted to know!


Ok, I wasn’t sure where to provide this feedback, so doing it here. I’m on 4.1rc1 now. Here is my report thus far:

  1. Tried in place upgrade on my desktop. Failed at Step 3. but I had a corrupted Whonix=15 template, not sure if that contributed to failure.
  2. So, I did a clean install. after a corrupted iso download, I was able to do a clean install, and all went well.
  3. After install,
    3.a. I am not seeing sys-usb? I configured to have it installed, so not sure why I’m not seeing it. Anyone experience this?
    3.b. Fedora-34 template seems to have been corrupted on the initial install. I had no apps showing up in there, and I wasn’t able to do an update on it. I couldn’t open a terminal window in it, since no apps were showing up.
    3.c. When I tried to reinstall Fedora-34 template, the testing template repo was not accessible. I had set it up to be enabled. I checked in /etc/yum.repo.d/ files. it showed as being enabled. But, I had to manually enable the repo at the CLI and then I could reinstall fedora-34
    3.d. Restoring backups: When I plugin my USB drive with backups, They are NOT showing up in the VM’s. Any of them. I had used sys-usb to do the backups on 4.0.4. But, since I don’t have a sys-usb in 4.1rc1 I’m not sure what to do.
    3.d.1. I"m realizing if the fedora-34 template was corrupted on install, that might be why the sys-usb never got created? and this could be why plugging in a usb drive and connecting it to sys-net (fedora-34 template) isn’t workign also? I’ll do some experimenting with this now.
    3.d.2. Yep that was the problem. fedora-34 being corrupted on install created the usb-drive connection problem. My keyboard and mouse worked though. so, curious about that.

I need to see if I can get a sys-usb VM setup now.

This is all for now.

to programmer of the qubes thank u for creating great technological achievement , u must done many hours of code long nights or days; users of qubes thanks to programmer

Is there also a minimal template of Debian 11 and Fedora 34?

yes, but i think it still very buggy

Can you please elaborate before stating such things please?

1 Like

I decided to try to do an upgrade to 4.1, and had a few problems:

Problem 1: Upgrade cannot proceed with non-Linux VM’s

I have a Windows VM and a FreeBSD VM. During the upgrade, an attempt is made to update all VM’s, which will not work with these VM’s. It’s not possible to proceed until these VM’s have been removed.

Problem 2: Strange qrexec confirmations during upgrade

Some time before stage 4, I got two qrexec confirmation dialog boxes. The first asked me to create a policy by typing “YES”. I don’t recall exactly what it asked.

The other one had one of the whonix-15 VM’s requesting operation _ (just underscore) and asking me which VM to send it to. I clicked on cancel here.

Problem 3: Stage 4 failing

Once upgrade proceeded to stage 4, the following error occurred and the upgrade stopped:

---> (STAGE 4) Upgrading to QubesOS R4.1 and Fedora 32 repositories...
INFO: Xscreensaver has been killed. Desktop won't lock before next reboot.
Using sys-net as UpdateVM to download updates for Dom0; this may take some time...
0 files removed
Fedora 32 - x86_64                              7.9 MB/s |  70 MB     00:08    
Fedora 32 - x86_64 - Updates                    7.7 MB/s |  30 MB     00:03    
Qubes Dom0 Repository (updates)                 134 kB/s | 4.0 MB     00:30    
Qubes Dom0 Repository (updates-testing)          99 kB/s | 1.3 MB     00:13    
Qubes Dom0 Repository (security-testing)        122 kB/s | 3.3 MB     00:27    
Qubes Templates repository                      4.5 kB/s | 5.9 kB     00:01    
determining the fastest mirror (15 hosts).. done.--  B/s |   0  B     --:-- ETA
Qubes Templates repository                      1.5 kB/s | 5.8 kB     00:03    
Qubes Community Templates repository            1.8 kB/s | 4.0 kB     00:02    
No match for argument: qubes-audio-daemon
No match for argument: qubes-gui-daemon
No match for argument: grub2-qubes-theme
No match for argument: qubes-artwork-plymouth
Error: Unable to find a match: qubes-audio-daemon qubes-gui-daemon grub2-qubes-theme qubes-artwork-plymouth
-> Launch restoration...

I have nitropad T430 with CPU i7 3840QM and 16GB RAM. I have used Qubes-R4.0 without any problem. I’ve decided to test the new version but it did not work at all. It was not possible at all to install it. There was just a black screen and nothing came up.

Maybe something wrong with iso or writing iso to flash

can you provide in detail, the steps you’ve followed, and the results, if you’d like support please

No I don’t think so
Because I’ve tried with different flashes. But when I tried writing other’s os iso to flash there weren’t any problems. I had issues only with qubes R-4.1

I’ve tried to do an upgrade in place which failed so I tried to do an fresh installation which failed too. When I boot from qubes R-4.1 iso flash so Only a black screen came up and nothing happened. waited around one hour but still nothing