Qubes on slow motion on new install


The problem

I am installing Qubes Stable (4.0.3) on my new laptop.

During this install and after the install, I encounter:

  • “gliding windows”
  • mouse moving jerkily
  • .5 sec delay at each keystroke

Basically, it’s Qubes on slow motion.

Happy to upload two small videos to illustrate if useful. (Is there a preferred method/place?)

What I have tried so far

Use Tails

Tails runs normally on the laptop without slow motions.

Disable the Nvidia Graphic card


  • I wondered if my problem could be related to my graphic card and

  • Nvidia is well-known to cause troubles with Qubes and

  • I saw these lines from dom0 → sudo dmesg:

    [ 5.897636] nouveau 0000:01:00.0: unknown chipset (166000a1)
    [ 5.897643] nouveau: probe of 0000:01:00.0 failed with error -12

I added nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off at the end of line beginning with kernel=vmlinuz... in the file /bot/efi/EFI/qubes/xen.cfg, then rebooted.

It did not help the situation.

Download kernel-latest


I typed in dom0: sudo qubes-dom0-update kernel-latest and then rebooted.

It didn’t solve the problem.

Some questions

I have difficulties discerning which errors in the log files (journalctl, dmesg) are relevant and which are not.
Should I post any log file here? Which one(s) would help? Which part?

How can I go forward?
How to pinpoint the problem?
Where/what should I look for to start with?

Your help is very much appreciated!!
Thank you!


I did some additionnal tests.

What I tried so far (additions):

Installl Qubes 4.0.4-rc-1

I tried to install 4.0.4-rc-1 (UEFI mode again).

The installer showed the same “slow motion”, so I did not go further.

Funny (?) display rate

Q menu —> System Tools —> Display… shows a Refresh rate of 77 Hz.
Isn’t this an odd value?

Installation with Legacy instead of UEFI

I don’t know if it makes sense to try to install in Legacy when the install (kind of) worked with UEFI.

At this stage, I’m trying every option that I can think of to make Qubes work.

I get:

When I understood how to handle try again with the inst.text bootoption, I was able to go one step further:

"qubes encryption requested for luks device 
but no encryption key specified for this device" 

(Figure removed since I am not able to post more than 1 media on this post)

Then I found @marmarek 's comment: “unlikely to be fixed in the near future […] but it’s still useful when using automated install”.

OK, no cheese down that hole, then.

Various error messages in journalctl

I tried to google error messages in dom0’s dmesg and journalctl without knowing if they are important or related to my problem.

Additional info

dom0 —> uname -r —> 4.19.155-1.pvops.qubes.x86_64 (after sudo qubes-dom0-update)


  • MSI GL75 10SFR-602
  • BIOS Version: E17E7IMS.109
  • Intel Core i7-10870H, including:
    • Intel UHD Graphics for 10th Gen Intel Processors, according to https://ark.intel.com/content/www/us/en/ark/products/208018/intel-core-i7-10870h-processor-16m-cache-up-to-5-00-ghz.html
  • Wifi: Intel wifi 6 ax201
  • nVidia GeForce RTX 2070

Conclusion & Questions

Knowing that:

  1. I’ve been banging my head on the wall without results for days now on this slow motion Qubes
  2. Moreover, sys-net does not show wifi networks. At first sight, my Intel wifi 6 ax201 looks very much like @lofidevops's https://forum.qubes-os.org/t/intel-corporation-killer-wi-fi-6-ax1650i-is-not-killing-it/2148. Consequently, I am currently updating through my raspberry pi.
    Thanks as well, @ludovic, for your precious inputs in https://forum.qubes-os.org/t/hcl-lenovo-thinkbook-15-iil-wip/2142/2
  3. Moverover, i have suspend/resume problems as well. I hope https://www.qubes-os.org/doc/suspend-resume-troubleshooting/ might help if all the other problems were solved.

So, with those 3 problems, should I bring my new laptop back to my reseller and try to be reimbursed?

I had Qubes on my previous laptop and I can’t imagine working with another OS now. That means I would have to buy and try another laptop, not knowing if that one will work better!?

@unman, is it possible to pay for 1-2 hours of consultancy? I would love to be able to move forward and to finally learn what goes wrong.

Thank you all for your answers to that post, help is very much appreciated!

Hi @katiehill,

first I haven’t a solution, but some ideas…

Some tests could imply a Qubes OS failure on next boot or no more graphic display (tagged with [/!\]), so do it only if you accept the risk and understand what you do.

First level ideas (display frequency / display device)

This is the most weird part of your post, you should continue in this direction.

  • try to change this frequency (maybe possible, maybe not, from the same setting panel)
  • try to change the screen resolution
  • connect an external screen and deactivate the lapop screen display (from the same setting panel)

Second level ideas (driver / BIOS / graphic tuning)

  • are you sure your are using the nvidia card and not the intel one? (see lsmod, xorg logs)
  • check the BIOS settings in general
  • check the main GPU choice from BIOS settings
  • try to use only the intel card (deactivate the nvidia from the BIOS)
  • in the BIOS, change the RAM size used by the intel card [/!\]
  • try some tuning with xrandr
  • deactivate the fancy tweaks and/or composition settings (Q menu —> System Tools —> Window manager (Tweaks))
  • check xorg logs (/var/log/Xorg0.log)
  • window manager logs: ~/.xsession-errors
  • xorg setting tuning (/etc/X11/xorg.conf.d) [/!\]
  • you said you installed the kernel-latest, after the reboot did you check the current kernel version ? (should be 5.x, neither 4.19.x, default and list is in xen.cfg) [/!\]
  • use the basic and low performance framebuffer xorg driver [/!\]

Third level ideas (input devices)

I think it’s a display problem, but you can also check the input devices.

  • check the mouse and the keyboard with the xev software in a dom0 terminal (terminal display reactive with the mouse/keyboard actions).
  • plug an USB mouse and/or an USB keyboard
  • try some tuning with xset (mouse, dpms, s)

I hope that one of the ideas will help…


Thank you so much for your answer, @ludovic!
I was completely in the dark and you helped me a lot!!

The first time I installed kernel-latest, I got a black screen and did not know it was possible to go further.

I re-tried and now it went through. I still have some minors trouble and I will maybe post again in the forum if I don’t find any solutions.

Thanks again, @ludovid!!

Hi @katiehill,

Great! Welcome to Qubes OS.

The forum contains a lot of resources, use its integrated search engine. Also, don’t forget the official reference documentation.

thank you, this advice helped me.


New seconds level ideas:

QubesOS 4.1 on my ThinkPad L15 (AMD Ryzen 7 Pro 4750U) with the default BIOS had delayed typing and wasn’t snappy enough. After I updated the BIOS it feels normal/smooth. Also smooth when display composition is enabled.