Qubes on Ryzen 7 pro 6850U elitebook 845 g9

I am trying to install Qubes OS on a new computer (elitebook 845 g9) with AMD Ryzen 7 pro 6850U.
After disabling secure-boot, and getting to boot the USB drive the installer gets stuck on Reached target basic.target - Basic System.
Booting with Debugging shows after this:
nvme nvme0: I/O 4 QID 0 timeout, completion polled

I’m not very experienced in linux systems, even though I’ve been using Qubes for a year now.
That’s why I don’t understand everything I’ve found about my problem so far.
Ryzen 7000 serie - This post is especially interesting, but I doesn´t understand so much. The point is that the new hardware is not yet fully supported.

Especially this post is interesting:

How can I implement this and would it help?

My general question is if there is anything I can do to successfully boot Qubes on my device or if further development will solve my problem.
I apologize if I am repeating a topic. I think Qubes is a fantastic project and I would like to use it on my new laptop.

This sounds sadly like something I’ve on my Lenovo T14 with an AMD Gen 3 (w. a AMD Ryzen™ 5 PRO 6650U Processor(Ryzen™ 5 PRO 6650U)) … but maybe HP doesn’t have the BIOS challenges I see with Lenovo.

The quick test is to add the XEN options when you boot the installer - so when it says “Install Qubes OS R4.1…”, hit e to edit the arguments for GRUB, locate the line that looks like

multiboot2 /images/pxeboot/xen.gz console=none

and add dom0_max_vcpus=1 dom0_vcpus_pin=1, so it becomes:

multiboot2 /images/pxeboot/xen.gz console=none dom0_max_vcpus=1 dom0_vcpus_pin=1

and press F10 (or Ctrl-x) and see if it will boot to the installer. If you have the “Qubes OS R4.1.2-rc1”, you can pick the “Install Qubes OS R4.1.2-rcX using 6.1.ZZ” … to get a newer kernel (with better support for the Ryzen).

Note: If the installer works, you’ll have to add it again when the machine boots from the NVMe … the changes are not permanent, but works fine to test. :slight_smile:

Can/will you test and report back?

1 Like

Thank you for your answer, I will try tomorrow, let´s hope the best :sweat_smile:

Seems to work for the rc version not yet tested with not rc version. Great thanks :ok_hand:. Is it after the second boot permanent? I would test further if every thing is working fine and will report back. thanks a lot

I have a 6900hs on a Zephyrus and can verify that using the `dom0_max_vcpus=1 dom0_vcpus_pin=1’ trick worked for getting Qubes installed, but not running post-install.

Nice that the installer works with:

dom0_max_vcpus=1 dom0_vcpus_pin=1


None of the changes made at boot time, are stored permanently. Since my machine doesn’t complete the “initial setup” correctly (current suspect is the Lenovo BIOS/ACPI issues) on the second boot, I’ve not attempted to make it permanent. I think you should be able to make it permanent, by editing
/etc/default/grub from a running/completed installation:

It’s been suggested, that you might get a better experience, is you can use:

clocksource=tsc tsc=unstable hpetbroadcast=0

as the permanent arguments to Xen (post install && initial setup). Since my machine doesn’t get that far, I’ve not had a chance to test it. :frowning:

Wrt. release, the Qubes OS 4.1.2 should be just around the corner – so it might make sense to just use/test 4.1.2-rcX (and report issues you find). :slight_smile:

1 Like

That is what I am doing. I have been trying to get my 6000 series ryzen to work for some time. From what I understand, you will NEED to use Qubes 4.2 test relies as 4.1 has an older version of Xen that does not support Ryzen 6000+.

After getting past the initial install, my PC crashes on “Setup Network”. At first I thought it was an issue with my Wifi 6e network card that I added. However, this does not appear to be the case as I also added an older wifi card from a previous laptop that DID work with Qubes… no luck, it still crashed.

Let me know if you make any progress, I do not expect Qubes 4,2 to be released in 2023, it has some pretty major changes.

Yes I have a similar problem, even though Qubes has everything set up correctly with the USB controllers and PCI devices. Neither Internet nor USB works. I think I will wait for 4.2. Although it is comforting that at least the install is theoretically possible.

1 Like

Addition: with adding x2apic=false to the previous, USB works for me now. I read that in a GitHub post. Issues with Lenovo Yoga Slim 7 ProX (AMD Ryzen 6800HS) Wlan does not work yet. I think this has something to do with the connected PCI devices, since my Intel card is not listed anywhere.

Was that on install, or first boot?

Are you sure it’s an Intel card? There’s and issue with Qualcomm cards in the g9/10 series, the Intel cards I tested worked fine in QCNFA765 (wcn6855) WiFi6 controller not working

I’m not sure if anyone has tested it with Qubes 4.2 yet, I’m hoping that new Xen will fix it