Qubes Installing on Huawei Matebook D16

Hello. I tried to run QubesOS on Huawei matebook d16, but I could not get the installer to start.
I looked at the “UEFI Troubleshooting” documentation section, tried to change the kernel parameters, but nothing worked.

I can’t capture the error on boot because the lines go by too fast. I think there might be some useful information at the end, but after the last one the screen shuts down.

Has anyone installed Qubes on this laptop?
How did you solve the problems? Or can you tell me how to make the screen not turn off?

This is an automatic translation, sorry.

Have you read this ?

I never face shutdown when booting the installer, can’t help if there’s no log. Maybe changing flashdrive will work.

and from my experience, you should use cpu only graphic if you do uefi installation and discrete only graphic if bios installation.

Yes. I read this. I tried other flash, and it still dont work. I capture screenshots. Some lines missed because all was very fast. This is best quality what i can do. 767.6 KB file on MEGA
I was wrong, the screen does not turn off, it just goes black. The last screenshot shows what happens before that.
P.S. My laptop have only CPU-integrated graphics.

Now I use Fedora 33. It installs without problems.

have you try with uefi / bios installation ?

like i said before, both are worked in my laptop with an exception.

what qubes version you try to install ? if it was 4.0.4
try with 4.1 it “maybe” work

iso https://ftp.qubes-os.org/iso/Qubes-R4.1.0-alpha20201014-x86_64.iso

signature https://ftp.qubes-os.org/iso/Qubes-R4.1.0-alpha20201014-x86_64.iso.asc

I tried to load qubes 4.1.0 alpha. I got typical grub menu but when I select value to start, I see this text:

error: no multiboot header found
error: you need to load kernel first.
error: you need to load kernel first.

I don’t know which kernel used in this Qubes build, but i know that many distributions with kernel oldest than in Fedora doesn’t work at this laptop. For example, MX Linux, PCLinuxOS, Artix. But openSUSE Leap with kernel 5.3 is work.
Maybe 4.1.0 doesn’t work because kernel is old.

// have you try with uefi / bios installation ?

I don’t try bios install. Which utility can write image in BIOS mode in linux?

I know, that old rufus can do it, but I don’t have native Windows now.

P.S. I tried to write Qubes images with balenaEtcher and dd.
P.P.S. Secure boot and TPM was always disabled.