Qubes gpu passthrough

Are there any groups online working on gpu passthrough for qubes? There are patches for Xen to do cpuid spoofing like how KVM does it so gpus (Nvidia especially) can work in a vm. I understand (or at the least don’t care) the security risks with it. I would like to help with the patches and figure out why the patches for Xen dont work with Qubes 4.1.



Hi, I’ve been looking for exactly the same thing, a solution get bypass code error 43 on the nvidia drivers in a windows VM.

I’ve think there may be 3 possible solutions :

  • installing custom nvidia drivers for windows (personally tried but failed)
  • patching Xen (somehow, probably by building qubes with custom sources)
  • installing and running KVM alongside Xen (again, I suspect, by building qubes)

I’m leaning more towards the third option at the moment, seeing as this exists : GitHub - nrgaway/qubes-kvm-dev
Similarily, don’t really know how this works or how to get it to work. Really lost here. I dont know the QubesOS project very well and need some help.

As a sidenote, I’ve been trying to build the 4.0 and 4.1 qubes images on fc32 and have been unsuccessful. Again, don’t really know how to troubleshoot that.

I’m hoping the community will help us.

1 Like

Yeesh. Still no support for this huh? Pretty much the only reason I came here. Getting ready to build my next “super rig” which I do once every 5 years. Was seriously considering moving permanently to q, but not gonna happen without full pass-through support. I’m sure I could get it working, but I don’t want the issue down the road of having to troubleshoot because an update is messing my stuff up. You ever get this working, inbouto? I know it’s been a while, but if you are and need help, feel free to hmu.

Nevermind–I went through the trouble of looking for this post only to find it was already posted by @fsflover. How do I delete posts?

4 posts were merged into an existing topic: Deletion policy

Nvidia GPU passthrough should work without issues with the new drivers. Tested it with two cards from GeForce 10 series and both of them worked.

1 Like

I think there is nobody actively working on this problem.
Since they mentioned 5 years ago that gui domain should be done, nothing.
I am also a little bit disappointment, but what can you do…

GUI domain is under active development and will be shipped with 4.1 -
you can test it with the alpha now.


I tested it.
both of them.
tried to tweek it, nothing
I did my best.
I really hope one day this will work

Care to expand? There is a thread for it: Sys-gui in Qubes 4.1 - devel.

Sorry for not replying sooner. Since the latest nvidia drivers now have beta support for VMs, I have gotten my 1070 to work in a windows VM in qubes 4.1 (and I imagine it would work in Qubes 4.0). Nothing special to make that happen besides rd.qubes.hide_pci so qubes doesnt use the graphics card. I did not use the gui domain.

The issue now is allocating more than 3.5 GB of ram to the VM, making sure disk performance is good, and possibly sound from the VM.

The ram issue supposedly has a work around but I cannot get it to work in 4.1. I have not tried 4.0 to see if I can get it to work there. See these threads:

I also tried a debian VM with passthrough and had the same issues of it not booting with more than 3.5 GB of ram. So the TOLUD change regarding ram did not seem to work in 4.1.

The issue now is allocating more than 3.5 GB of ram to the VM, making sure disk performance is good, and possibly sound from the VM.

If you have two audio controllers maybe you can pass-through one of them to the VM.