Qubes getting less reliable over time (Librem)

I’ve been using Qubes on my Librem for several months. At first it was mainly good but over time there have been more and more annoyances. Whereas in the beginning, suspend mode worked 80 percent of the time. Now it doesn’t work at all. I thought I solved that problem by just leaving the machine on all the time and Qubes would work fine for 5-6 full days without a problem. Now it works for about 8 hours before things start acting up, such as the choppy motion of the mouse. Ok, I will simply restart the machine. Now the internet does not work in Fedora but works in Whonix.

What should I do? Reinstall Qubes? Or is there a way to “tune” Qubes to fix these issues?

I assume you are using 4.0 fully updated: you dont say. And you dont say
what the specs are of your machine.

I use Qubes primarily on thinkpads - old ones. I dont recognise any of
your issues.
This isn’t particularly helpful, except that it might point you towards
the Librem side of things, particularly for the “choppy” motion and the
issues with suspend.
Since suspend didn’t work reliably from the start, I would go back to
Purism in the first instance.

When you say that “the internet does not work in Fedora”, I assume you
mean that Fedora based qubes cant connect after the reboot. This is strange.
Can you connect to an IP address? or ?

I’ve created another thread for this discussion. It’s called “Internet not working in fedora”. This way we keep it to one issue per thread :slight_smile:

A post was merged into an existing topic: Internet not working in fedora

I don’t see anything similar on my Librem 15. Suspend is reliable 100% of the time. Any logs?

Did you maybe appoint too low RAM to some VMs? I saw choppy behavior in such case.

I’m not using LIbrem laptop. It is the desktop version of Librem. I’ll fiddle around with the RAM and see if it makes a difference.