Qubes-firewall-user-script fails to execute on appVM startup

I tried implementing a DNS hijacking script in /rw/config/qubes-firewall-user-script on a standalone Mullvad VPN vm, but the script fails to execute whenever I start the vm. I’m not sure why it’s not executing, but seems like there should be an easy fix.

If I execute the script manually from the CLI it modifies the firewall as expected and everything works fine. I tried chown to see if user or root made a difference, but no effect. I ran chmod +x on the file and it has the same permissions as /rw/config/rc.local which executes normally. The qubes-firewall service is enabled.

It’s not really relevant, since the code works fine from the command line, but the hijacking script is found on this page.

I’d appreciate any suggestions on what to try next.

This may be a bug related to:

Looks like it’s a regression and we’ll have to wait for the bug fix. Since /rw/config/rc.local executes I implemented the following hack and it’s working now:

root@standaloneVM:~# echo “/rw/config/qubes-firewall-user/script” >> /rw/config/rc.local