Qubes External SSD HD and sys-usb

So here’s my latest Qubes Challenge:

I now have Qubes loaded on an external SSD HD using a usb 3.0 adapter and run via my Librem 14 computer (using Pureboot). I believe this is the reason that, when I’ve installed Qubes onto it, sys-usb never loads in the installation process. So I’m currently trying to manually create a sys-usb Qube that will read usb cards in the other usb slots (using the methods here).

Here’s where it gets interesting: even before any sys-usb creation Qubes will recognize the usb devices that I’ve plugged into the other slots but will immediately “detach the device” even though it’s still there. Furthermore, I can attach the device to any Qube, it will show that it’s attached, but won’t read the card whatsoever.

I’ve tried everything; including editing the grub file, the dom_0 commands to read the file, and I’ve crashed Qubes for the millionth time (giving me that “Entering emergency mode. Exit the shell to continue. ; Type “journalctl” to view system logs).

Any suggestions and/or expertise would be most appreciated.

This is perhaps obvious but you didn’t specify. Forgive me please if you did this.

I’m presuming you issued a Linux mount command in the qubes to which you attached your device? That is also a necessary step, attaching just makes the device available to be mounted.

Short answer, yes. The system crashed when I rebooted after I put the code into Dom_0:

I was following the instructions for hiding USBs from Dom_0 (perhaps that wasn’t the correct course of action but I’m trying anything at this point). I also tried usb and pci passthroughs but those didn’t work.

The code I input, after adding to the grub file was:
grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg (EFI) in dom0

Of course, I could be inputting the wrong code. Again, I’m grasping at straws here after trying the usb and pci passthroughs to no avail. Trying every which way to get Qubes to recognize USB storage devices.

If I’m using the wrong codes or if there’s a more proper method that I may have missed on the usb setup page, please let me know. Thank you.

You’re talking here about the boot process, which I never could figure out.

You originally said you’d attach the USB device to the qube, but couldn’t read it in the qube, which seemed to have nothing to do with how you boot the machine.

It made me think you perhaps hadn’t done sudo mount /dev/xvdi <your preferred mountpoint> (and there are additional parameters you might need for certain file system types on the mounted device or it ends up being read only–but using those parameters on any other file system will totally fail: -o uid=1000, gid=1000) If you don’t mount the object, you won’t be able to go to /dev/xvdi and read it. As I said you might have already known this, but your response to me makes it look like we’re talking past each other.

Not gonna lie; you could be part right with “talking past one another.”

But to clarify even further, when you make certain changes, especially to the root directory [dom_0], you sometimes need to reboot the machine for those changes to take effect. I rebooted Qubes after I made changes to Dom_0; trying to get Qubes to recognize the usb device.

Sorry for the communications error on my end. I was also at this for many hours straight.

I have a similar problem. I have installed Qubes OS 4.2 on an external USB SSD. This worked without any problems. But I realized that the sys-usb qube was not present.
I then followed these instructions here:
I installed the “sys-usb” qube. I did this because I also use a usb keyboard.
After that the system no longer booted