Qubes_dom0-root does not exist

Hey @gg1331, could you post the error you get? Also, could you add your current hardware configuration and a rundown of changes you (might have) made to relevant components?

1 Like

I think need more detalis for this solution

okay so what you see is emergency dracut shell, in the shell run lvm lvscan
example you found :

$ lvm lvscan
inactive   '/dev/qubes_dom0/root'
inactive   '/dev/qubes_dom0/vm'
inactive   '/dev/qubes_dom0/swap'

if lvm is founded and you see inactive simply active it by issuing :

lvm lvchange -a y qubes_dom0/root
lvm lvchange -a y qubes_dom0/vm
lvm lvchange -a y qubes_dom0/swap
swapon /dev/qubes_dom0/swap

I found this problem

run lvconvert --repair qubes_dom0/pool00, an please provide all the LV,

are you customizing disk when installing ?
as far i remember, it should be qubes_dom0/root-pool, pool00 is created because we do something to volume group.

This problem appeared after upgrading the templates . And I shutdown the device forcely due to system disruption

if vm is the problem try adding this to kernel option when you in grub menu qubes.skip_autostart so your kernel option is something like ............rhgb quiet qubes.skip_autostart

After writing …

lvm lvscan

lvm lvchange -a y qubes_dom0/root

lvm lvchange -a y qubes_dom0/vm

lvm lvchange -a y qubes_dom0/swap

try this instead.

lvm lvscan > a
less a

take a pict all of them.

after that, try this directly :
lvconvert --repair qubes_dom0/pool00

please don’t issue any command


sorry, add lvm so it be lvm lvconvert --repair qubes_dom0/pool00
if there’s no error anymore then

lvm lvchange -a y qubes_dom0/root
lvm lvchange -a y qubes_dom0/vm

after that type exit.

1 Like

In found this

Any update for this problem?

Still have the same problem

from redhat doc,


  • System failed to boot with below error messages


dracut: Read-only locking type set. Write locks are prohibited.
dracut: Can't get lock for VG


Boot system using rdshell option
Verify that locking_type is 4 in dracut lvm.conf file
Manually override locking_type using lvm vgchange -ay --config ' global {locking_type=1} ' command
boot system as root volume group is activated
Change locking_type to 1 ( or to 3 incase clustered locking) in /etc/lvm/lvm.conf file
Rebuild dracut image using dracut -v -f

Root Cause

lvm locking type was mistakenly set to 4 in lvm.conf present in initramfs image and lvm metadata modification operation was happening at boot time.

# grep locking_type /etc/lvm/lvm.conf
locking_type = 4

Are you using external drive for other use too ?

No. It is only for qubes


I think there’s a way but i can’t help you.
If there’s no important data you may reinstall.

1 Like