Qubes doesn't install when prompted

I went to the official installtion guide here: Installation guide | Qubes OS and downloaded qubes onto a 32GiB SD card with Rufus. I then wen to the BiOS and turned off secure boot (which is necessary to download qubes for me) and set my laptop to boot from the SD card first. This worked, and I got to the installation screen where there were 4 options. The top one said “Install Qubes OS 4.1.0” the next one said “Test Media and Install Qubes 4.1.0” the one below that said "Troubleshoot [something else in between but I forget what now] and Install Qubes OS 4.1.0 " and the last option was to “Save a Qubes OS System” I selected “Test Media and Install Qubes OS 4.1.0” and it started running through everything, but then the screen darkens again, and it returns me to the selection screen with the four options. I selected all of them, but they never work. I have tried multiple times. It does say there is an error when it starts trying to run, but then it seems to continue anyway. I will post the error here just to be safe.

[7.172578] dracut-pre-udev[634]: modprobe: ERROR: could not insert 'floppy':
Device or resource busy

Please help if possible.

Hi @Scarecrow, I’m glad you are interested in trying Qubes! It would be helpful if you told us what your hardware is.

This is what comes up from dxdiag

have you try with other flash drive?
are you creating uefi / legacy bootable ?
if you using legacy bootable, have you try using uefi ?
are there any option in your bios to select gpu settings like “hybrid mode, or discrete only mode”, have you try changing this menu?


I am booting on uefi, I’m not sure how to boot on legacy

I don’t think so but I’m not certain

based on this Interactive BIOS simulator
HP Pavilion Gaming Laptop 15-ec0xxx

There’s Legacy Support in Boot Options, change to enable, and try to create a legacy bootable medium with rufus.

So I have 15-ec2xxx,and it says my BIOS version is F.15, but in that simulator it says version B.05. When I look for a legacy boot option in my BIOS I do not see one.

It’s just an example and that should be not to far away from you updated bios version. You could upload a pict here about your bios if not sure, but i think there’s an option somewhere.

Does anyone have any ideas? I’ve tried everything I know.

I’m no expert, but after looking at HCL I suggest to do what other people with similar hardware do, e.g. this for Radeon GPU:

remove “noexitboot” and “mapbs” from BOOTX64.cfg for installer, Wifi & TPM do not work

or maybe this. Just guessing.

How do I edit BOOTX64.cfg?
Also, BOOTX is an EFI file for me

I think this guy had my exact issue: https://groups.google.com/g/qubes-users/c/m-GjKRgwvQ8/m/L0rw4nEXBAAJ
At least, from what I can tell. The issue is I don’t know how to do what he did, as he says to select “boot from EFI file” which I do, then go to “Anaconda”, which is not listed as an option.