Qubes boot option deleted

Hi all. I hope this is the right place for this question/discussion
Today I’ve encountered an issue with Qubes on my main laptop (Dell Inspiron 15, if that matters). I’m running Qubes for quite a while - around half a year I guess - with no issues whatsoever until today. This morning I used my Qubes just as any other day, but had to go out in a hurry. I closed the computer lid, disconnected it from the power cable, disconnected my USB dongle, and went on my way.

When I tried to open my laptop, the screen was black and the laptop unresponsive. Tried hard resetting the device (10-20 seconds press on the power button) to no avail. Assuming my battery may have run out, which often happens, I connected it to the power outlet and tried again, which also didn’t work.
Eventually I opened the lid, disconnected and reconnected the battery and the device started again (with 77% battery, which means this was not a drainage issue).
Only problem was - no boot options were available!
Trying to force the computer to boot to Qubes did not help.

I then used a USB device to run Qubes rescue, which also acted up by telling me that there are no partitions on my drive. lsblk DID however show my Qubes system and qube list.
/boot/EFI/efi did not have any files on it. Following the official Qubes guide and some forum posts, I managed to work around that by copying the required files, creating a new “xen.cfg” file, and using efibootmgr. Now everything is working correctly and all is well.

This whole thing raised some concerns on my side, as from my experience things don’t just get messed up on their own. So I’d love to hear some input, if you guys have any ideas on what could have caused this issue? The way I see it, this may be caused from:

  • A power surge while disconnecting the charger? This seems highly unlikely due to how those work + the fact that I disconnected it with 100% battery and apparently it managed to discharge to 77%. On my crappy device this means it ran for about 40min after disconnecting.
  • The fact I have disconnected the battery may have done something? The question as to what caused the black, unresponsive screen still remains, but this may mean that the black screen was one issue, and the boot option is another one.
  • This may be me being extremely paranoid, but: I used a disp-whonix to tor myself into a website which I do not trust, and have reason to believe they might have drive-by exploits (I am a security researcher, and this is a site I suspect is a honeypot from a nation-state. I know those exploits are rare-ish, but this is a possibility with such actors). Thing is - even assuming they had an exploit for tor over fedora, they still had to hop out to dom0 which is quite a feat by itself and then… what? What is it that an attacker may do to cause this? Again, this may only be me being extremely paranoid. This IS a scenario that requires multiple exploits to be used for a weird outcome.

I’d love to hear your inputs, as I don’t want this problem to reoccur. I needed my laptop today and this meant I did not have access to it without physically disconnecting the battery, which you can’t really rely on when on-the-go.

Thanks all.

I just want to make sure. Are you sure that you’ve mounted EFI partition and it was empty?
Maybe you’ve just mounted /boot partition without mounting EFI partition inside /boo/efi?
Try to unmount /boot/efi and check if there are any files in /boot/efi directory after this.
Maybe you’ve created new files xen.cfg etc in /boot partition in /boot/efi directory.

/boot had nothing at all, I have mounted my device’s hdd (/dev/nvme0n1p1) and there I had /mnt/hdd/boot/efi/EFI.