Qubes-App-Shutdown-Idle script not working Debian 11

Fresh 4.1 install and updated.

Installed Qubes-app-shutdown-idle package in Debian-11 templateVM.

The gui shutdown idle option is disabled

Also

Qvm-service —enable vmname shutdown-idle in Dom0 has no effect

Restart template, Qubes?
What is your /usr/lib/python3/dist-packages/qubesidle/idleness_monitor.py looks like?

1 Like

Looks pretty standard timeout is set to 15* 60 seconds

Yup restarted both multiple times

**Now get this ** when I create a clone of the Debian-11 template … it works (ie gui is enabled for shutdown idle)

I am truly perplexed. This is a fresh install and this was the first config I set after updating.

Rename the template to something else, rename the clone to debian-11, point all VMs that were pointed to the original template to cloned template and then delete original template.

Works for me.
The fact that a cloned template works, suggests that it works for
you.
If you want to troubleshoot:
Check the running processes in a qube - you are looking for
qubes-idle-watcher
Edit the config file to a short timeout.
Kill the qubes-idle-watcher process, and restart it.

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.
1 Like