Qubes 4.1 won't install while 4.0 does

Ryzen 5 3600 on ASUS PRIME B450M-A

udev fails to initialize during the systemd boot process on Qubes 4.1, which completely hangs the install process, as such I couldn’t get any journalctl.

I’ve tried various versions of Qubes 4.1 such as kernel-latest and none have worked.

So during my troubleshooting I decided to see if Qubes 4.0 worked by some fluke chance, and by my shock it actually worked and I managed to install it. I generated a HCL report to check if my hardware was qualified, everything required was enabled except TPM which was unknown.

Then I attempted to upgrade from Qubes 4.0 to 4.1 with qubes-dist-upgrade, after upgrading to 4.1 the system was once again bricked by udev failing to initialize and the boot process hanging.

After that, I managed to read the Xen logs that pass by quickly when you boot up the Qubes 4.1 install image, and noticed one error message: “xenoprof: Initialization failed. AMD processor family 23 is not supported”

Is this the cause behind the boot process hanging? I’m not sure, but something must have changed between Qubes 4.0 and 4.1 which has broken support for my CPU.

Any help would be much appreciated. Getting logs seems to be impossible due to the boot process hanging after udev fails.

1 Like

run in dom0:
sudo qubes-hcl-report


xl info

and post pics or info plz

just to see specs and capabilities!