Qubes 4.1.2 default installation fails with lvcreate timeout on SSD

Hi there,

I am using Qubes 4.1 on my desktop for one and a half years now and recently bought a new laptop that I also want to run Qubes on. However, installation fails shortly after start with an lvcreate timeout despite using mostly default settings.

System description:
Lenovo L15 Gen3 with a Ryzen 5875U. After unboxing and verifying the laptop works, I replaced the RAM with 64GB, which worked fine with the preinstalled Windows10. Then I replaced the original SSD through a virgin 1TB SSD.

Steps to reproduce:

  • Download (in a qube on my desktop) Qubes 4.1.2 iso and dd it to a 32GB USB 3.1 stick. Verify it via sudo dd if=/dev/xvdi bs=1M count=5881 | sha256sum and comparing the output to Qubes-R4.1.2-x86_64.iso.DIGESTS Do a sync, then detach the USB stick from the qube, then the machine.
  • Insert USB stick into laptop, switch UEFI to boot from it, select “Install Qubes OS R4.1.2” in the text menu, and wait a minute or two for the installer to boot.
  • In the installer menu, switch language to German with timezone Berlin, select the internal SSD with automatic partitioning and leave the “Encrypt my data” checkbox on, provide disk passphrase, add username and password, then start installation.

Expected behavior: Installation completes successfully

Actual behavior:
Installation fails with “An unknown error has occurred” after creating a disk label, formatting Partition 2 with ext4, creating an lvm in Partition 3, while “Creating ext4 on /dev/mapper/qubes_dom0-root–pool”. After clicking on “More info…” and scrolling down to the end of the exception chain, it says dasbus.error.DBusError: Waiting for 'LvCreate' method of the '/com/redhat/lvmdbus1/ThinPool/1' object to finish failed: Failed to get Complete property of the /com/redhat/lvmdbus1/Job/4 object: Timeout was reached

Related resources:

  • On the installation troubleshooting page it says this error may occur when the disk already contains some data and you should try with a n empty disk instead, but this is exactly what I did.
  • In another forum thread from 2020 it was recommended to do a custom disk partitioning, but I do not feel confident to do this with Qubes due to its complex use of LVMs, thin pools, etc.
  • I retried the installation twice, but the error has always been exactly the same. In between, I re-checked the integrity of the USB stick by comparing the sha256sum as described above.

I would be glad to get some hints on what I’m doing wrong and how to resolve this issue to get Qubes running on my new laptop.

1 Like

Here is a screenshot of the problem details with the lsblk info

version 4.1.2, default installation
same problem, need help.

So after about 20 unsuccessful attempts, including another USB stick, buying another NVMe drive, and various disk partitioning approaches (fully automatic, custom with recommended settings, or doing all the partitioning from a live system and just using the existing partitions in the installer), I successfully installed Qubes 4.1.2 yesterday. The solution seems to be dom0_max_vcpus=1 – and only that. Another thread recommending the 14" version for the HCL mentioned that dom0_max_vcpus=1 dom0_vcpu_pin are necessary to get the installer running, but the second option is not recognized and causes the installer to quit immediately in my case.
So in the end, it seems everything that was needed is hitting e after selecting Install Qubes OR R4.1.2 with the cursor keys, then replacing quiet by dom0_max_vcpus=1 and hitting F10. The installer then completes without problems.
I guess there is an issue in anaconda with regard to multithreading, so another thread tries to check if the logical volume creation or formatting has finished before it actually started, raising a Python exception. :roll_eyes:

1 Like

you are my hero!