Qube starts but applications are not launching

Hey Community,

I have a major problem with my one of my Qubes. It’s super important to get it back running as I have very sensitive information on it which I need.

I’m an absolute newbie when it comes to Qube/ codes or whatsoever so I would kindly ask to explain me things as if you are talking to your mother explaining an smartphone.

So heres the issue:
My Debian-10 Qube (standalone vm) suddenly stopped working. I did not update nor did I change anything in that qube. It literally stopped working from one day to another. The qube starts, I get the pop-ups that the qube started but no application starts. Not even the terminal starts. Nothing.

I can do: “sudo xl console -t pv VMNAME”, I get a reaction but it then asks for a login. I don’t know what to type in there. I tried my qubes login but it doesn’t work.

I went to Qube Settings and checked “run in debug”. I read that I can get some logs? But where are they? And what should I do with these logs? I’m probably not even able to understand them. So a step by step solution where to get/upload/post them would be great.

I tried cloning. It didn’t help. I also tried: “qvm-start-gui --all”.

I searched the forum to find a solution but nothing helped me. These tho come close to my problem:


Any help is much appreciated.

I just found this: Mount LVM image | Qubes OS
If I can restore the files through this, I think it would also help but I don’t understand fully how to do that. An step by step manual would be great. The qube that needs to get restored is named: “GroundedVM”

All my others qubes work well.

1 Like

Hi @newquber,

welcome to the Qubes OS world.


I suggest you test with qvm-run, see :

  1. starting-apps
  2. qvm-run documentation

Example in dom0:

qvm-run <name of your VM> xterm

Q from tray bar

You can also try to open a terminal from the Q domain icon in traybar.

Qubes Manager

The Qubes manager tool allows you to launch a terminal, access the logs, …

For the next time

Do backups, do backups, do backups :wink:, read the backup-restore documentation.

@newquber Specifically to access the logs you right-click on the qube » Logs

As a tip for the future, AppVMs typically allow one to avoid these situations. If it’s not booting all one has to do is to change it’s template VM. But having a qube just break is not to be expected so it’s perfectly understandable the surprise. Especially with sensitive stuff in there!

So, after checking the logs I tried with qvm-run and it actually worked. After once running xterm, i was able to open the other program through the “normal” way. So the qube actually works as it did before. Kinda weird but yeah. I add the logs… still kinda curious what caused the problem even though I probably won’t understand.^^

I think I tried opening a terminal from the tray bar but that didn’t work at that time. Thanks for you help.

Problem is solved, still I add the logs from before the problem was solved:

First log (/var/log/xen/console/guest-MYVMNAME.log:
When I click on logs, nothing happens.. no window pops up or whatsoever
Second Log (/var/log/qubes/guid.MYVMNAME.log)
Icon size: 128x128
Icon size: 128x128
domain dead
Failed to connect to gui-agent
Third Log (/var/log/qubes/qrexec.MYVMNAME.log)

Thanks for your help :slight_smile:


I’ve added here the “log” contents so the forum is more or less self-contained. You should also be able to upload .log files to the forum as attachments by dragging and dropping them to the upload area.

2 posts were split to a new topic: Debian 10 Template Broken