Proper guide on how to use sys-audio (AudioVM) must be created

UPDATED (TL;DR):

The best currently existing Guide about how to create and use audio qube (sys-audio) is made by @neowutran and available here:


Problem

Currently no proper guide exists on how to create and use sys-audio (AudioVM) in R4.1/R4.2.

  • Qubes OS Documentation does not have a single article about it.
  • Qubes Community Documentations also has nothing at all about it.

Consequences

So many people are trying to create sys-audio qube to listen to Bluetooth headphones and almost nothing helps or guides them except several forum topics which are mess: full of different information combined with useless, outdated or random messages on different topics. Almost nobody can set sys-audio to work properly in full.

Solution proposal

So, I am asking people who is savvy enough or/and have a properly working sys-audio to:

  1. Provide a detailed, up-to-date step-by-step guide how to create and set a sys-audio qube for having sound in it from the very beginning. Majority of steps should have an explanation of what (and why) is happening and how to test that the result of the step is right (check with aplay, reboot and check processes, look for something in pavucontrol and etc).
  2. Explain how exactly the sound data should be moved by qubes tools by design for future Qubes OS versions that will include sys-audio be default similar to how sys-usb is used nowadays.
  3. Provide a guide how to use Bluetooth headphones in this sys-audio qube to play sound in headphones.
  4. Provide a guide how to make the sound work in Windows qubes too (currently this topic is even messier, some patches of qemu and etc).

Let鈥檚 hope that someone (or multiple users) will try to do this important job for the greater good of others. It will be very appreciated.
I can make such guides myself but currently I am not able to set sys-audio for myself, facing multiple issues and lack of straight-forward information on the topic.

Links to information on the topic that I think can be useful

Uses, who supposingly has expertise or/and experience on the topic is bellow.

All these users are especially encouraged to participate within this topic.

6 Likes

Reserved comment.

The response is by far not overwhelming, so maybe I overestimated the struggle of Qubes OS users with sys-audio and Bluetooth headphones.

P.S. I managed to reroute sound of usual qube to Bluetooth headphones that are connected to sys-audio using device from sys-usb. On Thinkpad T16 Gen 1. There are a couple of places that I still do not understand fully, though.

That, and perhaps tagging/listing a bunch of users in hopes that one might fulfill your request, may not be the best approach, also taking into consideration the amount of resources that are required.

Although your request was well structured and some research was made, a better approach could be to start doing it yourself and ask when you need help. Users may be more inclined to reply to smaller requests.

My .02$.


Having said that, what are the places that you still not fully understand?

1 Like

Well, actually it鈥檚 more than a couple of places.
Let鈥檚 say I have sys-audio and test-qube with a audiovm set to sys-audio. I have no PCI devices in sys-audio, removed it in qubes鈥檚 settings, keeping it for dom0. I start sys-audio first and test-qube second.

  • Why pavucontrol does not reliably show volume bar from test-qube (almost never) before I reboot both qubes like 5 times? How to diagnose this issue and make it work? I see some users reboot sys-audio 3 (sic) times each PC boot to make it work, it鈥檚 awful.
  • Why after the first start sys-audio I have sound output from it (testing by aplay /usr/share/sounds/alsa/Front_Center.wav) though dom0 but after reboot of sys-audio it stops outputing sound like that? How to diagnose this issue? I would want to work it preferably the way it works on first boot - with a dom0 fallback in case I disconnect headphones.
  • Why do I still have errors and warnings as popup notifications about policies on qubes starts and bluetooth usb device passing? I added a lot of recommended lines from random guides to policies, but still some errors and warning are present. What warning even mean? I understand errors with denied resources, but warnings? How to diagnose, fix and make only the required amount. So many questions.
  • Why passing bluetooth device from sys-usb was not working with default fedora-36 template and I also had temporary change is to fedora-36-xfce? Maybe something should be added? I changed kernel of qubes to 6.* hoping it should fix things but it did not. The define should be supported with default kernel (5.12.* or later) as I found on some Intel page.
  • How passing volume is suppose to be working? Changing volume inside sys-audio only via some third-party custom scripts or is there any logic in Qubes OS that is intended for that?

I haven鈥檛 experienced this behavior. Mine works right away when it鈥檚 started the first time, no need for vm restarts.

Not a good way to diagnose problems. You may have inserted conflicting policies. You should understand what you insert in dom0.

Depending on your pci device, the required drivers may not be installed by default. This is an upstream issue.

You can configure keyboard shortcuts.

According to reports on forum - other people have it too. Right now I rebooted and pavucontrol in sys-audio (which iautor-starts on boot of the system) shows no bars for qubes that have it as audiovm. Should it be like that? What is the order of qubes to run, does it matter? How to diagnose? No information.

Are you sure allow policies can conflict?
I added recommended ones, well, 鈥渞ecommended鈥, because there is not proper guide, nor documentation.
And what is a good way to diagnose if there is no documentation?

No, it鈥檚 not a PCI device, but USB from sys-usb. And kernel has drivers as I told you above. Even the old one that goes with Qubes OS, but I tried a new one too. Messages from sudo dmesg are not providing useful information to me.

How? What should be changed, what is expected design by Qubes OS, does Qubes OS has something in mind on this matter (I suppose yes, according to policies)?

And why would you write a message like that, it has no actual information to add to my previous post and links I provided. Of course I can make some shortcuts to some commands, I mentioned it in my message (did not read?).
Another sys-audio thread is becoming a clutter that is not possible to read for other users. Sorry.

Why do you want that? You can ask sys-audio to also handle your stereo speakers, and that鈥檚 recommended since it鈥檚 more flexible.

The information is all there, just need someone to gather. I recently did a reinstall and configured sys-audio in one go, without any troubleshooting. The information in my thread is at least enough to make an ALC257 work flawlessly with sys-audio.

The reason I don鈥檛 do the gathering myself is, I cannot edit the original post that was marked as solution, because it was posted too long ago. And I don鈥檛 think reposting the same bulk of information everywhere is a humble action. You may encounter different issues based on your hardware specs, and I don鈥檛 think I鈥檓 skilled enough to build a bullet-proof solution for sys-audio.

1 Like

You didn鈥檛 specify the type of policies, you only said 鈥渞andom鈥.

Understanding the policies would be a good start instead of the 鈥渞andom鈥 approach.

Doesn鈥檛 matter where it comes from, still has to have drivers.

Ah cheers for clarifying mate, then you鈥檙e golden, eh?

It seems this information is already out there:

Did not use the search button, eh?

Do yourself a favor, if you want help, drop the sass.

It鈥檚 鈥渞andom鈥 because it is undocumented, why should they be added, what is the way those are used and why. Do you see any explanation on forum or anywhere? I do not.

I already told about kernel supporting the device out of box, even old one, I checked it before making the first post.

OK, I do not need your help, especially in a way you provide one, thank you.

My idea was to allow all qubes to work with speaker/jack-headphones, but others with bluetooth output. And even without bluetooth headphones those qubes will still play sound in usual way (but via sys-audio). If these feature is not supported then OK, it鈥檚 not a requirement, I just mentioned it. It just is not clear why rebooting of sys-audio changes behavior (it should not, imho).

I鈥檝e made up a newer version of the guide here Debian-minimal template for sys-audio - #74 by augsch. You can check it out, in case that it may help you.

3 Likes

Thank you, will try.

While I still wonder what the issue is, I have found that Bluetooth audio is a nice workaround, as documented here:

I would like to respond to this comment below:

I do not think that developers owe me or anyone an explanation on this issue. I share your desire to know the cause, but it is not their responsibility to identify it.

As I mentioned in the linked comment above, I think that the cause lies with the hardware itself. Hopefully someone from Purism can identify the cause of the issue someday, but since sys-audio is still a relatively new part of Qubes OS and is optional, I do not expect much investigation to be had anytime soon. I also think that I am probably the only person experiencing this issue, and it is not very important to me. I am very happy with my Qubes OS setup as it is.

I greatly appreciate the work being done by the developers of Qubes OS and other free software projects, and I think we need to remember that we are the beneficiaries of their free labor.

Just wanted to say I followed those latest instructions from @augsch (as well as subsequent bluetooth instructions) and it worked beautifully. Thank you.

3 Likes

I started trying to write a documentation: Document sys-audio 路 Issue #8093 路 QubesOS/qubes-issues 路 GitHub

WIP is below, if I missed important things please tell :slight_smile:

3 Likes

This was resolved sooner than I had expected:

Moved to Guides under User Support

I wanted to mention that following the guide from @augsch on qubes 4.2.0-rc1 and using the debian-12 template works just fine (this is from a fresh install), as well as bluetooth audio.

4 Likes

I also would like to see a how-to on using both bluetooth (and maybe usb also) headsets. My desire is to use bluetooth earbuds for listening to music or videos on the computer for the wireless convenience. I only care about audio out here.

I have a headset (AUX + a USB cable) that I use for conference calls. There I need audio out and in. USB adds some features, such as volume control and mike mute, so it would be preferable to AUX.