Problem installing on gaming laptop Asus Strix G512L

Hello everyone!
I am trying to install the Qubes OS on Asus Strix G512L.
Intel Core i7-10750H / RAM 16 ГБ / SSD 512 ГБ / nVidia GeForce GTX 1660 Ti

I downloaded an .iso image of the Qubes OS, wrote it to a USB flash drive via Rufus. When installing, I chose “dd image”.
In the BIOS boot settings i chose the USB flash drive first to boot.
When the laptop starts booting from the USB flash drive, I see the following text:

Xen 4.8.5-29 fc25 (c/s ) EFI loader
Using configuration file BOOTX64.cfg
vmlinuz: digit
initrd.img: digit

then the text appears in the screenshot below:
(XEN) ACPI Invalid sleep control status register data…

After this message the laptop starts to reboot. After the reboot, the same thing happens and the reboot is in progress again

Hi @itanschool ,
did you check your BIOS settings ? ( IOMMU, VT-d, VT-x, UEFI vs Legacy mode, …)

You didn’t say which ISO you tested (4.0.3 vs 4.0.4-rc2 vs 4.1-alpha). Your hardware is recent, did you try the 4-0-4-rc2 iso? in fact, the 4.0.4-rc2 installer includes a more recent kernel.

Yes, I followed the instructions in the installation guide. Intel virtualization enabled.
I’ve tried installing Qubes Release 4.0.4-RC2 and Qubes version 4.0.3. The result is the same.

But did you try Qubes 4.1? Perhaps it could work better with new hardware.

1 Like

Hi @itanschool,

I checked again your screenshot, first I saw the last lines about VT-d and IOMMU, but I checked and I got the same on my workstation:

(XEN) Intel VT-d iommu 0 supported page sizes: 4kB, 2MB, 1GB.
(XEN) Intel VT-d iommu 1 supported page sizes: 4kB, 2MB, 1GB.
(XEN) Intel VT-d Snoop Control not enabled.
(XEN) Intel VT-d Dom0 DMA Passthrough not enabled.
(XEN) Intel VT-d Queued Invalidation enabled.
(XEN) Intel VT-d Interrupt Remapping enabled.
(XEN) Intel VT-d Posted Interrupt not enabled.
(XEN) Intel VT-d Shared EPT tables enabled.
(XEN) I/O virtualisation enabled
(XEN)  - Dom0 mode: Relaxed
(XEN) Interrupt remapping enabled

Just note my 3 last lines after yours.

Then I saw the 7-8 lines about the CPU (unrecognized model), but my own CPU is near (i7-10710U) from yours, so maybe a more recent kernel but I’m doubting… Perhaps… (see the @fsflover advice for this)

So the better advices I think are :

  1. Check again your BIOS settings (not only


  1. Read the two below troubleshooting pages:
  1. Try without your nVidia card (if removable)

Hope this help…


Thanks for trying to help me.
I tried installing Qubes 4.1.
Panic on CPU 0:
IO-APIC + timer doesn’t work! Boot with apic_verbosity=debug…