Problem booting Qubes 4.1

Hope all of you are well. I recently downloaded qubes and installed it onto a usb. I eventually booted from the desired usb, and after inputing the encryption key and waiting a while, it gave some error code (included) and overall things I don’t understand. I would appreciate any help on the matter. I tried continuing but it didn’t work, and I tried the maintenance option and it brought be to a command thing I didn’t understand.

Give this a go:

Is there any chance of seeing the output of lsblk?

I only need the lines that are relevant to your USB drive that Qubes OS is installed on. You can remove the other lines if you’re concerned about privacy.

Basically, it’ll show us how far into the boot process it got. It if managed to load the volume group, you should see quite a few qubes-* drives.

I would be fine showing you, however the drive is no longer recognised as bootable. I have the boot order set to usb first, and when I booted it on my last post I had to manually boot it despite that. Now it is broken, so I’ll go through the long installation proccess again unfortunately. Some details about the drive I can provide : its a 128GB 2.0 drive. I know 3.0 would be faster, but they are signifigantly more expensive. The brand is infinitive, if that matters. Ill give more if I get brought to the same screen upon first boot.

  • it could be that, your lv is not actived, simply active it would resolve the problem
  • have you make sure that your flashdrive aren’t ejected ? simply run ls /dev/disk/by-uuid and confirm that usb is there. (i use a detached boot, and sometimes my flashdrive is unplugged, i mean not really unplugged, likely because got hit)

additional note, if you use uefi and plan to use this usb flashdrive for whatever reason don’t forget to copy the entry qubes folder on EFI partition to boot folder on the same partition, and recreate uefi entry pointed to this boot folder.