Please help me - Not asking for VMC because we don't have a network

As I understand you have the same issue as I had with two GPUs.
As stated here:

Yes the IPMI can only display via the graphics card that is integrated with the IPMI controller, on a SuperMicro this is usually a Matrox or an AST, as listed in the specs of the motherboard.

This can get especially interesting if you use a newer Intel CPU with integrated video, like the E3-1275 v5. The IPMI can only display video via the AST video card, not the onboard Intel card. If you are not using a C226 or C236 chipset, the integrated video on the CPU is likely disabled entirely.

The IPMI has its own GPU integrated in IPMI controller and there is another GPU in Intel CPU.
So when you boot your system with Qubes installer the video output goes to the IPMI GPU and you can see the image in KVM but when installer launch the installer home screen:


Then it’ll redirect the video output of this installer to the Intel GPU.
So in KVM you can’t see the installer home screen.
You can try to disable Intel integrated GPU in BIOS or hide this Intel integrated GPU PCI device in installer grub config so installer won’t switch to the Intel GPU.

Wow! :astonished:

That’s fascinating! I never would have figured that out on my own. The actual latest release is finished downloading so I’ll boot into BIOS and see if I can disable the integrated GPU there and report back to you.

I reached out to the host for my dedicated server and asked them if they could disable the integrated GPU and they said:

Dear customer,

I have verified and it seems the GPU is not powered for associated hardware, may we know which OS you trying to install.

We can help you install it from our end, please let us know if you need further assistance.

I went to try to go to the webpage you posted with the ISO links to give them a link so they could try to install it on their end and it seems that website isn’t working right now. I’ve tried from different browsers, and even from my phone and I can never get it to pull up.

Yeah it seems to be down for me as well right now.
You can get the ISO from the OpenQA then:
https://openqa.qubes-os.org/tests/39523/asset/iso/Qubes-20220507-kernel-latest-x86_64.iso

I checked again with my host and it looks like there’s no way to disable the integrated GPU from BIOS on this machine.

I was able to get to the installation with the ISO with kernel-latest and just before it goes into anaconda it shows these two “FATAL” messages and then it goes black again, I don’t know if that’s supposed to be normal or not so sharing just in case.

How would I hide the integrated GPU in the installer grub config?

You can modify the GRUB options on this Qubes installer screen: