Please help me, i lost my life

I didn’t have sys_usb in my qubes so I search online and found the qubes website guides on how to set it up. Fast forward, I added the usb controller to the sys usb I created and then BOOM. I am running qubes os on usb and now I can’t get it boot up again beause of this errors

Warning: /dev/mapper/qubes_dom0-roop dose not exist
Warning: /dev/qubes_dom0/root dose not exist
Warning: /dev/qubes_dom0/swap dose not exist

So basically I think because I run my os from a external SSD now that i pass all usb to the sys usb now dom0 can’t read the SSD drive it is on.

I HAVE IMPORTANT DOCUMENTS, ALL MY PASSWORDS INCLOUDING MY BITCOINS. I am shaking while writing this because I have no backup or anything. Please help me.


Hi @Jason, I’m not an expert, but this seems relevant:

1 Like

I didn’t lock myself out with keyboard or mouse, I can’t even boot the system right now idk how to recover from this :disappointed:

But the solution posted by 51lieal to that thread should also apply: just make usb devices visible to dom0 and prevent sys-usb from taking control over them.

In any case, the data are not lost. Booting from a linux livecd could be done to manually extract all the data if you can’t restore your Qubes OS installation.


Almost certainly nothing is erased. You can make a duplicate of HDD in case your are worried with clonezilla or even dd on another computer before proceeding further.

The problem is that your USB controller is not accessible from dom0. It is done for security reasons when user creates sys-usb by the salt script. Here is chapter about it: USB qubes | Qubes OS

So, first thing I would do for solving this is booting with custom kernel options. When you start Qubes OS you can choose advanced booting and modify kernel parameters. The change will not affect the system, only this boot will be different.

Namely, you should try to:

  • remove kernel option rd.qubes.hide_all_usb, it hides usb hdd from dom0.
  • add qubes.skip_autostart that will disable autostart of sys-usb, to prevent it from taking USB Controller from dom0.

Here is an instruction how to modify kernel options with images step-by-step for adding qubes.skip_autostart:


Bro I can’t thank you enough, I am new to qubes and I though I lost everything and your guide fix my problem under 5 minutes. You are a lifesaver angel :innocent:

It’s time to make backups now :+1:


I am glad it helped you and saved your life. :slight_smile:

Keep in mind that you still made no changes to the system, the next boot will be with default options, so you still should solve the problem with sys-usb and USB SSD. The solution will be to exclude USB controller with your USB drive from passing to sys-usb and pass all other controllers to it.

Hey, i just restart my pc and had the same issue then open the forum to ask but i saw your massage again thank you for follow up, i deleted the sys-usb qube so it don’t take any device from dom0 but still i have the same issue, how can i tell dom0 to to keep all the devices.

  1. Edit /etc/default/grub and remove rd.qubes.hide_all_usb in it.
  2. Regenerate grub config. The method of that varies between R4.1 and R4.2.