OS disappeared

It is the 2nd time that after I remove from the pc the HD with qube os inside and then I put it back the OS is completely deleted.
If i attempt to repair through the USB it ask me a password. I write a wrong password intentionally and it says it is wrong, then i write the correct One and it says there is no Linux partition installed…

So most likely something like the partition table gets corrupted. Which OS do you try on USB to repair the Qubes disk?
It is most likely a BIOS problem. It could be some hardware disk encryption that screws things up. I’m a big fan of hardware disk encryption and ususaly you have to beg the manufacturer to get it. I need more details about your hardware and bios before I can answer, IF I CAN, your concerns.

I have an Asus notebook. I’m using Qube iso from an USB stick to repair the boot.
I will note bios version tomorrow and come back to write here.

If for some reason you have some hardware disk encryption that erases the SSD with the manufacturers erase code, I’m very interested in getting a machine like that. Usualy you have to beg for BIOS hardware encryption. Yes it can be from the USB repair OS. You may contact me the next 3 days by searching MuWire for JamesBond007. The appimage is the easiest to install from MuWire.com

Before i have time to send BIOS info, i’d want to add that qube os do not vanish when i Simple remove HD and then I put it back. But it vanish when i remove the HD, i place and run another HD with Windows inside. Then i remove HD with Windows and i put back HD with qubes. In that case the OS completely is dematerialized.

Sounds like the TPM is doing the erasing. I would ask on the Asus forum. Which is the original SSD? Most likely the one with Windows. About 15 years ago Sony had a genuine parts tool that also created problems. Asus tech support may have a Q&A that will guide you to the correct person and a live chat (phone call).

The disks are normal HD that were natively with the PC when I purchased it. Both are original and same size but they have a different name code.
Thank you for your precious info I will post the bios info as soon as i can.

I try to inform from Asus support.
But TPM is a thing I can disable to avoid that?

Most likely the boot entry is missing on uefi, Try this on rescue shell

efibootmgr -v
efibootmgr -v -c -L QubesOS -l /EFI/qubes/grub64.efi -d /dev/sdf -p 1 (-d yourhdd/ssd, -p qubesbootpartition no

This happens with me too, Using ASUS motherboard. I stopped removing the USB and harddisk so it boots most of the time, When i do reconnect the OS entry disappears. The above method works.

Thanks I’ll try!

This is my bios

I tried that command lines but it still not boot ing. Maybe i wrote wrong sdx partition under dev. I dont remember what partition it was…

I would ask the question on Asus tech-support than I would ask for new BIOS from both ami.com and asus.

In Georgia there is a NATO location (basicaly a money pit) that is called Moxproject.com and it appears that ami has a division there.

I could go on but I don’t want my posting ban as before. I can direct you to some old BIOS hacking tools but you have to know what you are doing.

See if you have a setting that would allow to clear TPM and after you reinsert and see that Qubes is working.

The easiest is to get new BIOS from Asus and if your machine is not old enough return for money back.
The hardest is to search BIOS hacking forums for AMI/Asus hacks.

Seems that the new hard disk I used to install qubes is not erasing…
I’ll try it for some more days before using it officially.