Open URL links from gnome-terminal in disposable VM

This is a continuation of a GitHub discussion:


That works for me.

It’s likely an issue with your dvm. Could you start your dvm template
and run xdg-settings get default-web-browser there? It should be firefox
or chrome.

Also can you check your /etc/qubes-rpc/policy/qubes.OpenURL file in dom0
and share the contents?

Thanks. I didn’t realize it was just me that was having this issue. So, to first answer your 2 questions:
xdg-settings get default-web-browser” returns:

non commented lines in /etc/qubes-rpc/policy/qubes.OpenURL are:
$anyvm $dispvm allow
$anyvm $anyvm ask

I had assumed that since the man page said that the parameter was supposed to be a file, and not a url, that that’s why /usr/bin/qvm-open-in-dvm wasn’t working. but if it works for you. Hmm, i’m running qubes 4.0, not the new development 4.1 version if that’s relavant.

Also, note that the disposable VM starts, it then just halts without ever doing anything. I was assuming that it was launching, trying to transfer a file named “”, failing to do so, then halting and destroying itself.

Since it destroys itself, would I be correct in assuming that there is no way to get logfiles of what’s going on in the disposable VM?

Knowing that it works for you, I tried changing my template for disposable VM’s from fedora to “whonix”, and that worked just fine.

I personally can just use a different template, but should we keep going with this to see if the issue of passing a URL to fedora is a issue for everyone?

This is a known issue(#6562), and a solution is under consideration.

Thanks. We can close this “support request” and I’ll go back to the main issue on github.

Thanks again.