No Wifi on New Install

Hello! I have done a search but unfortunately wasn’t able to sort out my problem. I just installed Qubes and am not able to connect to wifi. I don’t see networks or any way to turn wifi on or off. All I see under network is “VPN connection”. The hardware seems to be okay because I was able to connect to wifi on the device with the prior operating system. I am also not the most experienced with these sorts of things so any assistance would be appreciated.

Most likely your sys-net template is missing wifi firmware. Is your sys-net based on Fedora or Debian template?
If it’s Debian then try to use Fedora template for your sys-net because the firmware there is newer.

I had a similar issue at first. I found a thread with a solution that worked for me, so here is the link and I will also copy and paste the comment that had the working solution:

Download kernel-latest

Dom0: sudo qubes-dom0-update kernel-latest

Maybe not necessary but if you need kernel-latest to make to wifi card work, there are chances that you need it in Dom0 to make the rest of your (recent) hardware work as well.

Download package to make kernel-latest available to AppVMs:

Dom0: sudo qubes-dom0-update kernel-latest-qubes-vm

Stop sys-net

(Setting a Fedora template might be needed, not sure)

Update kernel for sys-net:

Qube Manager → sys-net → Advanced tab → kernel → Select kernel-latest

Set the right kernel options for sys-net:

  opt=$(qvm-prefs --get sys-net kernelopts)
  qvm-prefs --set sys-net kernelopts "$opt iwlwifi.disable_rxq=1"

Start sys-net. Wifi should now be available.

If this doesn’t work, then I probably won’t be able to help much further because I am also new to Qubes.

Thanks for the suggestions. Unfortunately, my issue continues. Sys-net is set to fedora in the template manager. I also tried updating the kernel but got error messages which seem to be due to lack of any internet connection (since the wifi isn’t working and I don’t have ethernet).

Check the log in sys-net with sudo journalctl and search for errors related to the wireless controller.

when installing qubes, your installer in grub boot menu maybe allows kernel-latest, try using that while you install the OS.

if its to late in the progress and you need to rescue your installation i have no idea how to get the kernel-latest package from the install medium.

Reinstalling that way worked! Thank you!

1 Like