No success installing Qubes on newer Intel system


I have issues installing Qubes OS on my Intel system (about 1 Year old, MSI H510M Pro with latest BIOS, Core i5-10400 using iGPU, NVMe SSD). The 4.1.0 installer shows grub menu but doesn’t launch graphical installer. The screen becomes inactive like in standby regardless which option I choose from grub menu. I tried all video outputs on the motherboard. Since I always verify the installation media and the 4.1.1-rc1 installer completes installation on the same USB drive, the installation media should be fine. Qubes 4.1.1-rc1 installation completes, but ends with UEFI boot issues: when the installer reboots I’m stuck in my motherboards UEFI which happens when there are no bootable devices detected. I tried other linux distributions and some of them work (kali), but some not (debian) and show a similar behavior (inactive screen). Maybe it’s a kernel issue and only newer kernel can boot with my hardware, but I wonder because the CPU was released 2 years ago.

I read about missing legacy mode for newer Intel processors and my motherboards UEFI indeed seems to ignore changing the boot mode from UEFI to CSM, so legacy mode probably won’t work for me.

Maybe I have 2 options how to solve this issue:

Getting 4.1.0 installer to work
This would be my preferred solution since I prefer stable releases and don’t like manual edits after kernel and xen updates. But since other linux distributions also have screen issues, this may be the wrong choice.

Getting 4.1.1-rc1 UEFI boot to work
When I boot into rescue, I enter my password for encrypted partition 3, but the result is “You don’t have any Linux partitions. Rebooting.” So I enter 3 to skip to shell, mount the first partition and try to solve my problems with the following troubleshooting sections:

  • Boot device not recognized after installing
  • Installation finished but “Qubes” boot option is missing and xen.cfg is empty / Installation fails with “failed to set new efi boot target”

The first section seems necessary since my BOOT dir is empty after installation. But there are deviations like different filenames (grub.cfg instead of xen.cfg for example).

The second section doesn’t match the part “failed to set new efi boot target” since I see no error message during installation, but I guess that I noticed a new boot entry “UEFI Hard Disk: Qubes” in my motherboards UEFI after handling this section, which may have created the Qubes entry in UEFI. But even after setting this boot entry to first position does not help and I always return to motherboard UEFI. Another deviation when following this section is that I don’t create xen.cfg since I had grub.cfg after installation.

Please, can anybody help me getting a working Qubes installation?

Greetings and thank you very much.

What’s your Intel CPU and the hardware system?

The Core i5 10400 Gen12 may have some sort of race against AMD, but the system booting device may have been removed during the initial installation or the kernel latest (5.18) still has the bug with in it.

1 Like

If you have a graphics card, you can try not using the internal graphics. I have a newer MSI motherboard, and the internal graphics was given me a lot of problems.

1 Like

Thank you both for your help. Did I provide enough information about my hardware? I always thought I had a 10th Generation CPU…

Sorry, I have no other graphics card, but it would be funny when I need to buy one, since Qubes system requirements strongly recommends Intel integrated graphics processor. Does this problem mainly concern MSI?

I don’t think it’s a problem with the intel graphics, my problems got solved by replacing the bios firmware.

I was having similar issues with the display not turning on, but was only when I tried using the internal graphics, my nvidia card was working just fine.

1 Like

OK, so there may be a good chance that my hardware works with stable release when I use a popular graphics card. Good to know. Meanwhile the latest release is up and running, apart from changing some filenames on EFI Partition I also had to change the filename for the loader parameter when creating the boot entry with efibootmgr in rescue shell: I used grubx64.efi instead of xen.efi and also dropped that strange placeholder parameter at the end.
Thanks again for your help.