No services or qubes will start successfully on fresh install (T430)

Please forgive my ignorance, I’m a total noob to qubes. I’m familiar with linux and basic terminal commands, but nothing fancy (am learning, in currently taking courses for that in uni).

I’m using a lenovo thinkpad T430 which I understand is a supported device. There’s only 4gb of ram, but I have ordered 16gb replacement and am waiting for it to arrive in the mail.

When trying to run a qube it will attempt to start, and then immediately shut down. For example with sys-net and sys-usb. When trying to run anon-whonix I get the error “failed to start: internal error: libxenlight failed to create new domain 'sys-firewall”. When searching for this error I’ve seen some similar cases, but none of the solutions offered worked for me. I tried disabling all of the services automatic start on boot and restarting qubes but that didn’t make a difference, either.

If someone could point me in the right direction I would be very grateful. Could it simply be the fact that I don’t have enough ram yet? I would think that at least one qube would be able to start, even if extremely slow.

Thank you

1 Like

dom0 uses 4GB by default. Maybe no memory left for running anything else? 4GB is below minimal system requirements.

1 Like

It is that simple. The minimum requirements is 6 GB.