No network connection after MAC randomization

Hi guys,

i tried to randomize my MAC address while scanning and connecting.

For this I use this how to

Every time I create this 00-macrandomize.conf in a template and then I use this for my sys-net or new NetVM´s. But after I can´t connect to my router. Both wifi and ethernet can´t build up a connection.

What I still notice is that my NetworkManager have very old versions. Partly 1.16 (fedora 30) and 1.22 (fedora 32). Every time I search for updates for these versions the already installed versions are shown as newest. The same applies to Gnome Network Manager.

So far I have done the following:

  1. build a new template
  2. create the 00-macrandomize.conf in the right place
  3. create a new NetVm or make sys-net to use the new template.
  4. restart all VM’s
  5. the network connections are tried to be established but cannot be connected.

What am I doing wrong? And if really necessary how exactly do I get the newer Network Manager versions?

Before I try this again I installed Qube’s OS 4.0.3 completely new and updated it.

And before the question comes… I absolutely need this for my work.


Maybe your router has some MAC address whitelisting?
Try connecting to your mobile Wifi to make sure it’s not a Qubes OS issue.