No Internet connection on Debian template - how to create dvm template

All of a sudden my internet connection for debian template disconnected. but I have net for anon.whonix template

What’s the problem? for connecting to putty I need internet

Also Am I able to install putty on anon.whonix template as well?


Please elaborate. What do you mean the connection for the template disconnected? TemplateVMs should not be attached to a NetVM. Updates are done through a proxy.

You need to installing in whonix-ws-16, then shutdown the template and restart anon-whonix.

Thx for your quick reply.

I mean when I open “debian 11 - Firefox ESR” I can’t open any site. also I can’t connect to SSH through putty which I just installed it.

I opened whonix-ws-16 terminal & entered this comment:
sudo apt install putty

But I don’t see putty in the list of applications yet! Even I refreshed & shut down but no success

Because you are opening Firefox in debian-11 which is a TemplateVM and you are not supposed to do that. Instead, you should be creating a DispVM (Disposable VM) by launching one from the debian-11-dvm menu: Open the Q menu and find Disposable: debian-11-dvm. Launch Firefox from there.

Run sudo apt update before the install command.

It seems from your post that you might not know exactly what you’re doing, so may I suggest that you read the Getting started guide: Getting started | Qubes OS

Running software/connecting a template to net may be considered a security risk, so keep that in mind while you’re managing your VMs.

You may find the glossary useful: Glossary | Qubes OS

Right, Not only I’m new to this OS but in working on linux command as well.

When I click on Q I don’t see Disposable: debian-11-dvm. For disposable I see only these two:

So how can I add debian here?

Not a problem, we have plenty of resources to get you started the right way.

Check my answer here: Best way to use veracrypt in qubes - #2 by BEBF738VD

Replace deb-veracrypt with debian-11 and deb-veracrypt-dvm with debian-11-dvm.

result for first command:
app: error creating VM: VM debian-11 already exist

result for second command:
bash: qvm: command not found

You tried to create debian-11 but you need to create debian-11-dvm:

[user@dom0 ~]$ qvm-create -t debian-11 -l red --prop template_for_dispvms=true --prop netvm=sys-firewall debian-11-dvm

You didn’t type the command correctly: it’s qvm-features, not qvm -features (no spaces):

[user@dom0 ~]$ qvm-features debian-11-dvm appmenus-dispvm 1

Double check that you’re typing everything correctly, including the spaces.

sorry to bother you, I had no success for both command.

first one:
app: Error creating VM: template for DispVM (debian-11) needs to be an AppVM with templates_for_dispvms=true

second one:
I’m typing without space

bash: dvm-features: command not found

You’re right, I made a mistake in the command. I updated it and this one will work.

It’s qvm-features not dvm-features

jusr run this on your dom0, if you want to use firefox based on fedora

qvm-run --dispvm fedora-36-dvm firefox&

since you dont have debian dvm template, do this

qvm-clone fedora-36-dvm debian-11-dvm

open qubes manager, right click debian-11-dvm
change template to debian-11, click apply and ok.

now you can run firefox based on this debian dvm

qvm-run --dispvm debian-11-dvm firefox-esr&

Thx fo your help. Now I was able to create debian & everything is works.

But the problem is it’s not on anonymous mode. How can I run browser/putty on anonymous mode. like anon.whonix

No problem, you should select it as answer so that question can be considered resolved.

To run a browser behind sys-whonix, it’s recommended that you use a disposable vm based on whonix-ws-16. To do that, open the Q App Menu and find Disposable: whonix-ws-16-dvm and launch Tor Browser from there.

If you want to install putty in the whonix template:

[user@dom0 ~]$ qvm-run -p -u root whonix-ws-16 'apt update; apt install -y putty'
[user@dom0 ~]$ qvm-shutdown --wait whonix-ws-16
[user@dom0 ~]$ qvm-shutdown --wait anon-whonix

Then you’ll be able to run putty in a whonix vm.

In the future, please separate different questions into different posts.

Sure, I just entered the command you gave me.

I got this error:
qvm-run: error: no such domain: ‘apt update;apt install -y putty’

Put the VM name before the command. See updated instructions in my previous reply.

1 Like

Thx, I installed putty on whonix. Now when I connect to ssh it doesn’t show my original ip. right?