No boot after update

Dear all,
qubes 4.1.1 doesn’t boot after system updates.

After a post I created some time ago (where some good soul tried to help without success) I decided to start from a clean installation of Qubes, but I always obtain the same result…

Here’s some detail:

  1. I create a fresh Qubes 4.1.1 installation
  2. I restore some VM from a backup
  3. Everything works fine until I decide to update qubes. I don’t remember if it’s a specific update, but I’m talking about standard stuff: debian/fedora template, whonix, dom0…
  4. After the update I can continue to use everything as normal, but as soon as I reboot, qubes doesn’t boot anymore.

Here’s what I get:

Warning: /dev/mapper/qubes_dom0-root does not exist
Warning: /dev/qubes_dom0/root does not exist

Generating “/run/initramfs/rdsosreport.txt”

Entering emergency mode. Exit the shell to continue.
Type “journalctl” to view system logs.
You might wanti to save “/run/initramfs/rdsosreport.txt” to a USB stick or /boot
after mounting them and attach it to a bug report.

Press ENTER form maintenance
(or press Control-D to continue):

— [after Control-D]

Warning: Not all disks have been found.
Warning: You might want to regenerate your initramfs.

This is what i tried:

$ lvm lvscan
A get the list of my vm, everyhing is inactive except /dev/qubes_dom0/swap

I tried the recovery procedure using a live usb installation
It say that the linux partition was not found.
I tried fdisk -l from the console, and I see the partitions

(3) I tried several suggestions from other similar posts, but I haven’t found any solution

Any suggestion would be very appreciated…

Would you be willing to redo the install?

I’m pretty sure it’s a dom0 update that changes something related to the grub menu/config - so if you would be willing to do yet another installation, the it would be interesting to compare the grub config from the installer with the config after the update.

My suggestion is:

  1. Install Qubes
  2. Check the current grub.cfg (in dom0):
sudo ls -al /boot/efi/EFI/qubes/grub.cfg
  1. Make a copy of the grub.cfg config (in dom0):
sudo cp /boot/efi/EFI/qubes/grub.cfg /boot/efi/EFI/qubes/old_grub.cfg
  1. To check if you can boot with the backup, reboot the computer and when you get grub menu, press c and type:
configfile (hd0,gpt1)/efi/qubes/old_grub.cfg

If this works, then I think you can try the dom0 update and compare the old and new grub config (in dom0):

sudo diff  /boot/efi/EFI/qubes/grub.cfg /boot/efi/EFI/qubes/old_grub.cfg

Notice: I’m running UEFI - I don’t know how the legacy installation is. :-/