NextCloud or ProtonMail in 4.1

Try to run the nextcloud client or the protonmail-bridge in a VM in 4.1. It closes all the windows open in the VM, and there’s no way to open any new windows, even using

$ qvm-run vm xterm

from dom0.

The VM remains running, however. I can kill the VM and restart it and open a terminal, but again, when running either of those two programs, it will crash heavily.

Here are logs from that vm (I called it “e”):

/var/log/xen/console/guest-e.log:
[2021-04-17 18:18:31] Fedora 33 (Thirty Three)
[2021-04-17 18:18:31] Kernel 5.10.28-1.fc32.qubes.x86_64 on an x86_64 (hvc0)
[2021-04-17 18:18:31]
[2021-04-17 18:18:31] [press ENTER to login]
[2021-04-17 18:18:34] [ 12.593673] kauditd_printk_skb: 67 callbacks suppressed
[2021-04-17 18:18:34] [ 12.593675] audit: type=1130 audit(1618708714.505:79): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=systemd-hostnamed comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:18:35] [ 13.927666] audit: type=1106 audit(1618708715.838:80): pid=545 uid=0 auid=4294967295 ses=4294967295 msg=‘op=PAM:session_close grantors=pam_keyinit,pam_limits,pam_systemd,pam_unix,pam_umask,pam_lastlog acct=“user” exe="/usr/lib/qubes/qrexec-agent" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:18:35] [ 13.927753] audit: type=1104 audit(1618708715.838:81): pid=545 uid=0 auid=4294967295 ses=4294967295 msg=‘op=PAM:setcred grantors=pam_rootok acct=“user” exe="/usr/lib/qubes/qrexec-agent" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:18:36] [ 14.509350] audit: type=1130 audit(1618708716.421:82): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=polkit comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:18:36] [ 14.932644] audit: type=1106 audit(1618708716.843:83): pid=520 uid=0 auid=4294967295 ses=4294967295 msg=‘op=PAM:session_close grantors=pam_keyinit,pam_limits,pam_systemd,pam_unix,pam_umask,pam_lastlog acct=“user” exe="/usr/lib/qubes/qrexec-agent" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:18:36] [ 14.932733] audit: type=1104 audit(1618708716.843:84): pid=520 uid=0 auid=4294967295 ses=4294967295 msg=‘op=PAM:setcred grantors=pam_rootok acct=“user” exe="/usr/lib/qubes/qrexec-agent" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:18:36] [ 15.342683] audit: type=1130 audit(1618708717.254:85): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=rtkit-daemon comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:19:06] [ 45.075938] audit: type=1131 audit(1618708746.987:86): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=systemd-hostnamed comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
[2021-04-17 18:19:06] [ 45.096681] audit: type=1334 audit(1618708747.008:87): prog-id=24 op=UNLOAD
[2021-04-17 18:19:06] [ 45.096713] audit: type=1334 audit(1618708747.008:88): prog-id=23 op=UNLOAD

/var/log/qubes/guid.e.log:
Icon size: 128x128
ErrorHandler: BadValue (integer parameter out of range for operation)
Major opcode: 12 (X_ConfigureWindow)
Value: 0x0
Failed serial number: 1537
Current serial number: 1540

/var/log/qubes/qrexec.e.log:
Empty

Any hints on making this work?

very strange, I run both nextcloud-desktop and protonmail-bridge in f33-based vms, and that works fine.

Hmm. This is the third fresh install with progressive 4.1 ISO’s. Happened every time. Also using F33. Given the unhelpful logs, I’m not even sure where to start the debugging process.

It’s working for me as well, both with 4.0 and 4.1 (Fedora & Debian).

I guess you are not new to Qubes, are you?
I am asking because there are always questions concerning software where people don’t know or haven’t read about where to install it. For example, the protonmail-bridge has to be installed in the template your protonmail-appVM is based on.

Other than that I don’t know where to begin helping you because usually the configuration window should start after a while and after configuring protonmail autostart each time you open your thunderbird.

Yep. Works perfectly in v4.0.4 and earlier. And, yes - it’s installed in the template.

The only thing I did differently when installing v4.1 was to use BTRFS, rather than LVS. No way this could be affecting anything, right?

No, I use BTRFS as well.
I still use F32. Did you try with F32 or Debian?
Edit: Sorry, at the moment I use Debian with protonmail.

Haven’t used either F32 or Debian. I’ll try!