[new user] OnlyKey App troubleshooting

first off, thank you for your patience.

On the first qube (debian 11 based) i downloaded and installed the onlykey-app in the personal appVM, got it to open, however it wont notice my onlykey device when plugged in (stuck on ‘working’)

on the second qube (fedora) i downloaded the application using snap & i haven’t been able to see the application on the menu once i have closed, reopened, and refreshed.

was unable to get onlykey cli to work as the pip3 command required for one of the entries doesn’t seem to work

I’ve been at this for about 5 hours.

Can anyone help explain the proper installation process for the OnlyKey app from the start, so that i can get this working from the get-go?

Thank you for your time.

Maybe this can help

1 Like

Seems like you know what you’re doing. You’ve tried basically all methods! Sad to hear it hasn’t worked yet.

Have you attached your device via USB to the specified qube? See:

Hum. Weird. I don’t know too much about snaps, but that shouldn’t be happening. Could be a bug.

I installed the onlykey-app 5.3.5 in a debian-11 template. Then I made that template a disposable-template(which is needed for sys-usb) in 4.1. Then I made sys-usb point to that disposable template I just created.

Atleast this is how I got it to work and recognize the onlykey. I tryed to get sys-usb to point to a normal template but I couldn’t get that to work and this was my alternative.

Haw exactly did you do this?

I’m still trying to figure out how to install it to the template rather than the AppVM. I cant seem to connect out to github and pull the file for download

creating a disposable template link https://www.qubes-os.org/doc/disposable-customization/#creating-a-new-disposable-template

Install Applications/Software in a template is also in qubes docs. https://www.qubes-os.org/doc/templates/debian/

im reading the docs, but each time i sudo apt install https:github/blahblahblah it responds with:
[unable to locate package blahblahblah · GitHub]
Am i missing a required proxy or a specific update?

Thanks for your help

templates don’t generally have internet access so you wont be able to do like that.

The easiest way is to install it from a .deb file. Download then verify the .deb file (using an appvm with internet access) then move it to the template.
Here is a download link onlykey app v5.3.5 then use dpkg to install it in the template.

Here is a link from from the onlykey docs using onlykey on qubes-os

i was significantly overcomplicating this without following basic instructions. thank you for your help sir! I did exactly that and everything works fine. I did however install firmware for the onlykey using the app on a seperate device (as per a few other comments ive seen around)


1 Like