New user feedback - running into walls

Hi, this is my second time attempting to install Qubes (the first one failed repeatedly a month ago so I gave up), and I wanted to provide some feedback from the perspective of a technical user (Linux since the 90s, Ubuntu as a daily driver for 3+ years, software developer).

I’ve installed Qubes on a ThinkPad X1C CORE i7, which I assume is supported hardware. I chose the option to create the USB qube under sys-net.

The first wall I ran into was this error during installation:

The second wall I ran into was that after rebooting and logging in, I couldn’t get online! I didn’t see anywhere in the system tray a or the XFCE menu a network/wifi icon or anything obvious to allow me to get online. This breaks several basic usability guidelines of the project - “Make it easy to discover features and available actions”, not “Require extensive configuration before a user can begin doing things” etc.

I think getting online is a critical path to most users, and an onboarding wizard would greatly help here. Reiterate to the user in the OS why dom0 must not have networking (mentioned in the Getting Started guide, which I did read), and show the user how to enable it in a specific qube (or in sys-net? I’m still confused at this point). Also, the guideline about not using acronyms should be taken heed in regards to “sys-net”. Can that be named something more user-friendly?

Anyway, I wasn’t alone in being unable to get online. Pages like this should not have a need to exist:

I can’t quite recall what I tried before discovering that guide, but I kept getting numerous persistent popups (4+ of them),

Qube Status: sys-net
Domain sys-net has failed to start: internal error: Unable to reset PCI device 0000:00:1f.6: internal error: Unale to reset PCI device 0000:00:14.0: no FLR. PM reset or bus reset available.

then another popup with pretty much the same error, but about sys-firewall.

Talk about “Avoid Acronyms”, “Use Simple Words”, " Avoid Technical Words" and " Don’t Leave Users Stranded" :-/

I went to the sys-net Qubes Settings from the XFCE menu, and the Networking was set to “(none) current”. That seemed like the obvious issue, so I tried setting it to “default”, “sys-net” etc. Every time I did that, I got a

ERROR: Basic tab:
Loops in network are unsupported


Then I tried to follow that Bytefreaks guide, and it turns out it was written for an older version of Qubes. In the end I found out where the Applications tab was, and I added “Settings” there. I think Settings should be among the default shortcuts. However, clicking the XFCE menu → Service: sys-net → sys-net: Settings, does nothing (and BTW, there’s another usability guideline broken there, " Avoid Duplicate Words".

I still don’t know what exactly happened that let me go online, but now I see the red Network widget. I tried to take a screenshot by pressing PrintScreen. Saw an option to “Host on imgur”. How convenient! Except it didn’t work, “An error occurred while transferring the data to imgur”. Then I chose “Copy to the clipboard”. Good luck pasting that anywhere though (Discourse supports pasting images here, but the clipboard never contained the screenshot, no matter what combo of Ctrl+Shift+C/V I tried.

“Clipboard fetched from vm sys-net… Copied 0 bytes to the clipboard”

I ended up taking a photo with my phone, and opening Google Photos in the Personal cube. I still wasn’t able to copy the image from that cube into this one; I could only copy its Google Photos long URL (~700 characters), which I managed to paste here, copy the image, then paste it in the Discourse tab.

[Discourse bans me from uploading more than one media item in my first post, so I’ll add that screenshot to a separate post]

TL;DR - doing basic tasks with Qubes has been a very frustrating experience so far:

  • no welcome wizard (the one from Mint is good inspiration)
  • no help from the OS to get online
  • cryptic network errors, even though WiFi did work without running any terminal commands to configure it
  • Settings for the qubes not easily accessible
  • copy/pasting images across qubes apparently impossible
  • hosting screenshots on Imgur broken
  • no shortcut key to take a screenshot of an area of the screen (I tired Shift/Ctrl/Alt+PrtSc combinations, it seems only screenshotting the entire screen is possible
  • XFCE is really barebones - no search, mouse cursor doesn’t shape when hovering over links in Firefox etc.; but I understand this is due to be replaced by GNOME. Ideally, I’d want to see an option during installation to select the DE - I’d want KDE for example.
  • confusing XFCE menu - I see “Domain: vault → vault: Firefox”. OK, I get that. But what’s “Template: debian 10 → debian 10: Firefox ESR”? Does it start a disposable new Qube and launch Firefox? Can all those templates be organized under “Start new qube”?
  • outdated out of the box - I clicked Template: fedora-30 → fedora30: Software. Big red scary error that “Fedora 30 is no longer supported”.

I haven’t even tried doing anything productive yet; I’ve been fighting with the OS for the past couple hours, so expect more feedback :slight_smile:

1 Like

This is the Fedora error:

In the beginning the progress bar was empty for a good minute. I didn’t know if the download even started. Progress bars without a numeric percentage should start with at least something visible.

Then there are the two Cancel buttons - what does the bottom one do? Cancel the restart requirement?

Also, Firefox 71 → 76? Isn’t Firefox at 85 now?

1 Like

Unfortunately, Qubes is pretty fussy about hardware - far more so than Ubuntu - and your first issue is related to that (the errors preventing sys-net from starting - see my HCL Report for a link on how to fix this problem).

I’m not sure why you had this problem - the Qubes Settings option appears in the menu for all of my VM’s.

It’s interesting that one cannot copy images to the clipboard - I wonder if this is a bug, a deliberate decision or a limitation of the technology? In any case, you can save the screenshot to a file and then use the qvm-copy-to-vm command in a terminal session to copy it to another VM (see Copying from (and to) dom0. Not a great workflow I admit. (BTW, the imgur option doesn’t work as Dom0 has no network access for security reasons - I guess the option is there because it’s in the upsteam package and the Qubes maintainers don’t want to customise it to remove the option).

Have a look at TemplateVMs. Unfortunately, because Qubes is very different from other versions of linux, reading the docs is essential even for experienced linux users.

Yes, it would be good if there was an updated ISO available.


Thanks for the tips, @Rooftop.

More on the Fedora update: I started the System Tools → Qubes Update app when I wrote my first post, and in the meantime it completed dom0 and fedora-30 and just finished whonix-gw15. However, that Fedora progress bar from the image above has been stuck for the past 30 minutes at about 55%. Is it possible that Qubes Update finished updated it before that Fedora software update itself did? I clicked the dark grey Cancel button next to the progress bar about two minutes ago, but nothing has happened still. Clicking the other Cancel button does nothing either.

I don’t think Software Update works (I presume because Template VMs don’t have any network access). I’m not even sure why Software Update is in the Template VMs menu?

I always update VM’s using either Qubes Update or using dnf (or apt) from a terminal session.

1 Like

For an update like that you probably want to just install the latest template from the repo.

sudo qubes-dom0-update qubes-template-fedora-32 should do the job.

See “installing” in TemplateVMs | Qubes OS.

Qubes Upate just finished. It lists dom0, debian-10, fedora-30, and 2 Whonixes.

  1. I noticed that debian-10 was greyed out. Why wasn’t I able to update that TemplateVM? From the Qube Manager, I was able to right click on the debian-10 qube, and choose Update qube. That update is going on right now.
  2. Does what @Jarrah wrote suggest that now I have a Fedora 32 TemplateVM misleadingly named fedora-30?

1.It was greyed out because your system is not yet aware of any updates

  • when you start a template based qube, the qube will check for updates,
    and this will be notified to dom0. If you have not opened a debian-10
    based qube, then this wont have happened.
    There is a check box for updating templates regardless of whether there
    are known updates: look and you will see it.
  1. No - why would it? Presumably you have an updated fedora-30, not an
    upgraded template. If you read the docs you will find advice on
    updating and upgrading your templates. (Hint - read the docs)

Thanks for the feedback @qubesnewbs. I’m sorry that you’ve had a bad experience. Qubes is a still a challenge to get into (including myself). It takes persistence and lots afternoons reading the documentation. But in the end it pays off as you are in much more control over your own system.

Regarding usability hasn’t been a big priority for Qubes development. After all, the team has limited resources and a quite a big objective already. But there have been recent efforts in giving more focus to Usability as UX designer joined the Qubes team recently:

And will also be the subject of my master’s dissertation.

You have a lot of feedback / issues and I understand you’re fed up with this and just put it all in one post. But the issues you experienced in particular could be addressed individually. People here are willing to help, but in this format it is quite chaotic.

See this thread:


Hallo @qubesnewbs and welcome to the community! I am familiar with your struggle. I am not a technical user. I’m a law major. It took me 6 months of attempts, and the release of 4.0.1 to be able to install Qubes my laptop.

Today, my recommendation is to install Qubes Release 4.0.4-rc2 instead of 4.0.3, especially for new hardware. Sometimes, even the latest release will not support your hardware, so you would need to install kernel-latest and/or kernel-latest-qubes-vm which, I admit, are not easy to figure implement for a new comer. However, lacking IT expertise and knowledge myself, I did find the documentation to be very helpful after the initial months of testing.

Prior to me installing Qubes the first time, I had watched the few available videos back then. There are way more now on YouTube. These videos helped figure out the basics that allowed me to begin several months of learning. (But see warning here for these videos)

However, I faced and still face some problems and shared these problems on this forum (example).

Regarding reset PCI device, it happened to me and I fixed it by asking on this forum and researching around the internet. The solution was to go to settings of the Qube where there’s the problem, then: > Devices > Configure strict reset for PCI devices > disable for the 0000:00:14.0 in your case.

And final note. it would be good if you share your laptop model/year to help people with the same laptop find this thread.