New pc (dell 3535 2023), 4.2.0rc4 install : no network

I’m installing Qubes OS (4.2.0rc4) on a new laptop (dell 15 3535, ryzen 5 7520u, no graphic card, no built-in rj-45 adapter).
Installation gone right, rebooted and it showed an error during configuration :

['/usr/bin/qvm-start','sys-firewall'] failed:
stderr:"qrexec-daemon startup failed : 2023-12-03 22:26:05.065 qrexec-daemon[17789]:qrexec-daemon.c:144:sigchld_parent_handler: Connection to the failed

I thought it maybe was because the laptop had no network, though the system installed pretty well, it could run into it, but without network, as I could not attach an external usb to rj-45 adapter in the sys-usb vm, and the sys-net vm kept on crashing each time I launched it with the same error message as above.

So I reinstalled all from scratch, usb network attached -and network connected … though I dont think Qubes OS needs the network during installion, rather on the opposite all network is certainly off.
I did not had the error during configuration (or “post-installation”), but :

  • sys-net keeps crashing at every launch attempt with the above message (a bit shorter "qrexec-daemon startup failed : 2023-12-03 22:26:05.065 qrexec-daemon[17789]:qrexec-daemon.c:144:sigchld_parent_handler: Connection to the failed " , and the pid and the timestamp are of course new ones)
  • I can see the usb devices after launching, I can attach them to any vm … that does not require sys-net !

It is a bit resembling to Qrexeq-daemon startup failed 35:sigchld_parent_handler: connection to VM failed, with a fresh install though …
Any idea ? Where can I find logs to investigate this sigchld_parent_handler error ?

Check which PCI Wireless controller do you have attached to your sys-net.
Probably it’s RTL8821CE which is causing a problem, you’ll need to install specific kernel module for it to work.
You can search for more info on this forum if you have this PCI Wireless controller.

1 Like

Hi @apparatus
yes, indeed I do have a rtl8821ce in this machine :frowning: .
I have first tried to reinstall with latest Qubes OS iso installer highest kernel (6.5.6-2.fc37 instead of default 6.1.56-1.fc37), but it changed nothing :sweat_smile:.
I have a nice kernel panic in sys-net (which has this rtl8821ce device attached in its settings), and kernel driver in use is pciback while kernel module is rtw88_8821ce.
Having parsed the forum I understand I should blacklist rtw88_8821ce and use 8821ce instead (especially from here).
I will also find a way to download this module onto this machine (from another machine and a usb drive I assume).
I’m searching.

I can close this topic as I have a workaround (or maybe is it clearer to me now).
First with similar topics I learned to have the sys-net use provided by qube kernel, which allowed it to run.
Then … I simply don’t need rtl8821ce, as I don’t use wifi :flushed:.
For info, upgrading kernel to 6.6.2-1.fc37 allowed the sys-net to launch without crashing. But it was not responding after resume, so I simply detached rtl8821ce from the VM.
And when plugging in a usb rtl8153 ethernet adapter and adding it to sys-net via sys-usb, I have the network running :smile:.

I wanted to reopen the post as I’m taking the time to fix the issue (aka installing another driver for RTL8821CE chip, to enable wifi at last).
I’ve read a few posts related to the same issue on the forum, and especially this one, but I thought I was mistaking something :

  1. My sys-net template is debian (debian-12-xfce currently)

  2. I could build the driver from GitHub - tomaspinho/rtl8821ce … but I confused things, I was in disp-fedora qube, I thought I could copy the 8821ce.ko driver file anywhere else

  3. but … btw, the last kernel update brought me to current 6.6.9-1.fc37 kernel … and … the driver problem is “self-fixed” !! Last kernel update fixed the bad RTL8821CE driver (presumably).