Network Printer install question

Hi all,

I am following the Qubes Documentation how-to guide and followed a couple of other how tos on the net about network printer install. I keep running into the same problem that I cant figure out

I created a dedicated debian TemplateVM for this printer install. I start the system-config-printer dialogue, and I come across a popup window to join a user workgroup. Asks for a password. I try different combinations of the passwords/user/usernames that I created during Qubes install nothing works.

I also tried going through the browser cups interface http://localhost:631, same issue, asks for user/password when I try to add a network printer

Then I tried the install in a dedicated debian Qube AppVM, same issue.

This is for a HP officejet 7740
Any assistance around this would be greatly appreciated


Perhaps a stupid question, but could this be a printer-specific password from its documentation?

It sounds like username/password for cupsd - I’ve not tested network printing, but I think /etc/cups/cupsd.conf requires something like:

AuthType Default
Require user @SYSTEM
Order deny,allow

before allowing changes to settings.

Hi all,

Sorry for the late reply

The cupsd password didn’t work, still asking for password


You need root privileges: sudo system-config-printer.
(or modify the permission as said by ChrisA (don’t forget to reverse them after))
You have a dedicated template only for printing.
So its “ok” to do this in the template, but still not recommended.

A better way is to use a disposable template, and configure the printer there (with bind-dirs).

You could also run sudo system-config-printer in a disposable qube (or your print qube).
Once your printer is configured and system-config-printer closed.
Copy /etc/cups/printers.conf and /etc/cups/ppd/PRINTER_DRIVER.ppd to the template.
Reboot the template. It should work.

Great Thank you for that, wasn’t running as root this whole time,

Will report back once I test

Thank you for sticking with me so far