Nested VPN Tunnel Timeout / Reset Issue

Hey Qubers,

I have been using Qubes-Tunnel for a while now and I have yet to iron out this issue.
I require the use of nested vpn tunnels in order to access a private wireguard server that is blocked from a public network I use. So, my configuration to get it working is to run my browser VM through two sys-vpn qubes before hitting sys-firewall. The first sys-vpn has the server key, and then the second is a paid vpn service that is accessible from the public network.

I have tried 3 configurations (wg via openvpn, wg via wg, wg via tor) and all work, but all have the same issue: every 30 seconds or so I get a connection timeout/reset. Same issue with 4.0 & 4.1 using either debian or fedora based sys-vpn qubes.

To be clear, the configuration is:
browser-vm > sys-wg-server > sys-wg-paid > sys-firewall > sys-net

Has anyone else tried using nested vpn tunnels in qubes and encountered this issue / found a solution? And is there someway I could log this timeout in order to provide the forum with more info?

Thanks!