My system 76 compatible

Sorry for this but I am not a tech guy. What part of my system is not compatible:
8GB GTX 1070, 3.6 GHz-i7 6820HK, 32 GB Dual channel DDR4, 512 GB NUME PCL M.2 SSD

Many thanks,

My guess is that you need to disable the Nvidia card in your BIOS and use the integrated graphics. That is the usual culprit. Also disable secure boot and switch to legacy boot if you can.

Your CPU definitely works (has Vt-d and two successful HCL reports). There are also plenty System76 devices in the HCL, which are generally made to work well with Linux.

I am pretty confident you can install Qubes OS on your machine. Maybe share a little more detail?

  • what the model you are using?
  • what happens when you try to install?
  • which version… R4.0.4 or are you trying R4.1?

Thanks Sven, I have a System Oryx Pro laptop. Qubes R4.0.4.
I get the message: Unsupported Hardware Detected. Missing Features:
10MMu/VT-d/AMD-Vi, Interrupt Remapping

This feature lacks hardware required by Qubes. Without these features Qubes OS will not function normally. It is recommended only developers and power users proceed with installation.

I decided what would happen if I continued. On the “Installation Summary” page there was a yellow triangle next to: Installation Destination-No disks selected. I had the option to select one of my drives.
Select the device you’d like to install to. (Does this mean Qubes would have overwritten the OS I presently have on the drive?) I was hoping to run it from a USB if that is possible.

@notechie wrote:

Oryx Pro

There are two such systems in the HCL. Both required some troubleshooting but none mentions any issue with Vt-d.

There is a longish thread here, that involves installing R4.1 on a USB drive … but I didn’t read it all.

Unsupported Hardware Detected. Missing Features: 10MMu/VT-d/AMD-Vi, Interrupt Remapping

As mentioned before your CPU supports Vt-d. There have been a couple of instances in which Intel sells two chips with the same name, one supporting it and the other doesn’t … but I couldn’t find any evidence of that being the case with your CPU.

Maybe there is a BIOS setting to enable “virtualization support” or something like that?

I was hoping to run it from a USB if that is possible.

You can install it on a USB drive by selecting that drive in the installer. However the performance will be impacted obviously.

Bottom-line: I remain positive on this laptop being able to run Qubes OS, however this brief research also made it clear that this endeavor will entail some troubleshooting and by no means is a “just works” affair. So given that you describe yourself as “not a techie” maybe this is too much trouble.

If you want to try Qubes OS, I’d highly recommend getting one of the computers mentioned in this list. Most of them are around for a while and available to be purchased on eBay.

You could also try and get in touch with the people who reported using an Oryx Pro as linked above and ask for some guidance.

1 Like

Thanks Sven, appreciate your help!

1 Like

I enabled the Vt-d and tried to install Qubes again and everything looked great until I clicked on the Work domain and got this from, sys-firewall and work:
Domain has failed to start: internal error: Unable to reset PCI device 0000:6d:00.1: internal error: Active
0000:6d:00.0 devices on bus with 0000:6d:00.1 not doing bus reset

Is this repairable or should I abandon it and look for other options of working with Qubes.

I just went through the troubleshooting in the Documentation and what I did worked. I believe I have Qubes on my System76 OryxPro2. It feels awesome, now to read the Documentation and using the OS.