My Qubes broke again. Can't see network


I have a desktop and multiple operating systems.
I added an ORIENT XWT R81L2PE network card to my desktop
On all OS everything is compatible and works perfectly.
After that I downloaded Qubes. The network has stopped working.
Connection Manager cannot connect.
I don’t even know where to look, where to look for the cause.
Tell me how to connect the network.

Hello, let’s try to get to the bottom of this.

Could you elaborate? Are you saying that you see wifi networks/eth connections but cannot connect to them, or you cannot see any network? What do you see when you open NetworkManager?

Do you see your card if you run nmcli device show in your netvm? (this contains identifiers such as hw address, please don’t share such identifiers)
And what if you run lspci in your netvm? You should see it next to Network Controller.

What template are you using for your netvm?
Have you tried searching and installing the correct drivers in your template?
Depending on your template, you can try installing (missing) packages as listed here (look for your template and check the NetVM paragraph; it also explains how to search for the appropriate firmware): Minimal templates | Qubes OS
You could also try switching to another template: if you’re using fedora, try debian (and vice-versa).

Sorry for the numerous questions, but this requires more info.

Just a side note I think it’s worth mentioning: it’s not recommended to have other OS besides Qubes as it may pose a security risk, depending on your set up.

Read more about it here:
\ Frequently asked questions (FAQ) | Qubes OS
\ Contents/ at master · Qubes-Community/Contents · GitHub
\ Dual boot with windows

Having said that, it’s not the topic of this conversation so you shall do what fits your needs.

Qubes is on a separate disk. on another linux drive. everything else in virtualbox. I always think what could happen

Did you add your new network card to your netvm (sys-net by default)?
Q → sys-net → Qubes Settings → Devices
You need to have your network adapters in the right column.

As you suggested - added. But maybe it’s from the settings on the router. I changed gateways for different network cards. Where are these network settings to fix them?

Right click on the network connection icon → Edit connections.

Not work

For now you can remove other Ethernel controllers except the one that you use for connection to exclude their influence on the problem here:
Q → sys-net → Qubes Settings → Devices
How do you determine that it’s not working?
Can you ping your gateway from sys-net terminal?
If you ping your gateway from your other non-Qubes system with the same network settings then ping works?

I immediately did so, left the interface that worked. Run the ip address command in the terminal. ENS6 interface without address. I tried ip link set ens6 down/up but no result.
After entering the terminal, the network settings that I manually registered disappear. I don’t know what happened anymore. The last time before the shutdown was a big update dom0, maybe this is the problem. On Linux my gateway ( normally responds.
In which file can I change the settings ENS ?

When you change settings via GUI by clicking on the network connection icon → Edit connections then your settings will be saved persistently in /rw/config/NM-system-connections/ sys-net directory and will be restored on next start.
If you just change the network settings in /etc/NetworkManager/ then they will be discarded after you shutdown sys-net.

It definitely doesn’t work. When you start a terminal, all static is cleared from the connection manager. 100% working interface.
For check lifted dhcp. Turned on the Qubes and the network started working. Connection established.
Conclusion - the developers need to put this moment in order.
So that not only in the connection manager you can register statics, but also, for example /etc/network/interfaces

It works for me.

  1. Right click on the network connection icon → Edit connections.
    Enter your network settings.
  2. Right click on the network connection icon → uncheck Enable networking
  3. Right click on the network connection icon → check Enable networking back

This procedure was done several times.
I do add a static address, I also specify dns - I save it. Next, right-click to turn on the network. Looking for 1sec. the network is connected. I look at the settings. There is no longer a static address, and the manual mode has changed to automatic dhcp. I don’t know why static settings are removed and forced to use dhcp.

Check if Network Manager creates config file in this directory in sys-net terminal when you press on Save button:
sudo ls /rw/config/NM-system-connections/

I disabled the connection created via dhcp. Opened the sys-net console. There are directories only /rw/config. It contains scripts. Created a static address through the manager, clicked save. Nothing has been added to the directory. There is no such directory `/rw/config/NM-system-connections/’

What template do you use for sys-net?
What’s the content of NetworkManager directory?
ls -la /etc/NetworkManager/

total 36
drwxr-xr-x   6 root root  4096 May 18 20:57 .
drwxr-xr-x 132 root root 12288 May 18 20:57 ..
drwxr-xr-x   2 root root  4096 Apr 12  2021 conf.d
drwxr-xr-x   5 root root  4096 May  5 17:20 dispatcher.d
drwxr-xr-x   2 root root  4096 Apr 12  2021 dnsmasq.d
drwxr-xr-x   2 root root  4096 Apr 12  2021 dnsmasq-shared.d
-rw-r--r--   1 root root   111 May 18 20:57 NetworkManager.conf
lrwxrwxrwx   1 root root    32 Apr 20 18:10 system-connections -> /rw/config/NM-system-connections

Then what’s inside /rw/config/?
ls -la /rw/config/

if I’m not mistaken, this is a link (link) system-connections to the directory /rw/config/NM-system-connections/ which is not