My experience so far using Qubes 4.1

I know I’ve seen some of these issues posted around different places, so please forgive my if I’m just re-iterating what’s already been discussed I just figured I’d post here, summarizing all of the issues and questions I can think of so far that I’ve been unable to solve yet.

  1. Sensors doesn’t have as much info (e.g. IIRC in 4.0.4 I could read CPU temperature, in 4.1 it does not appear). Does anyone else experience this? I haven’t seen anyone mention it.
  2. Suspend doesn’t work because the system never wakes up afterward, and requires full power reset. Tried setting mem_sleep_default=deep but it didn’t seem to change anything. A fix it to change SMT (e.g. hyperthreading) setting, which does fix it so it awakes/resumes from suspend, but now I face an issue where qubes appears broken (sys-net, sys-usb, etc… has to be restarted to regain functionality).

And here’s some I’m not sure are 4.1 specific:
3. sys-usb sometimes doesn’t startup after boot, has to be launched manually.
4. An error notification Denied qubes.InputKeyboard from sys-usb to dom0. appears whenever device connects to sys-usb I think, so I assume that some setting is specified to try and automatically connect to dom0. Where to find and disable this setting?
5. How does the ask policy work for input devices (keyboard, mouse) and/or sys-usb? When I use the ask policy in qubes.InputKeyboard and qubes.InputMouse, from what I can tell all it does is make “automatic” attachments fail (hence 4. above), and approve any “manual” attachment requests. Well, I’m not sure if “automatic” and “manual” attachments are fundamentally different actually, but that is the behavior I have experienced. No prompt is given. This might not be qubes
6. Minor thing and maybe xfce and not qubes specific: Is it possible to use keyboard navigation to select/focus the topbar in the XFCE desktop UI (e.g. applications, various windows, workspaces, etc…)?

Any insights to these problems and questions would be much appreciated.
In particular, I’m hoping someone has info about 1. as I haven’t seen anyone talk about it.

1 Like

See also: Various suspend problems and Is it 4.1 mature enough to use it as a daily driver?.

1 Like

Some of these are issues that have been logged and are being worked on.
4. The sys-usb notification should not appear for all usb devices. It may
appear with some devices which present as keyboard input devices - some
mice do this, some USB storage devices. But not all.
5. If you set the policy to “ask”, then indeed automatic attachments
will not work because you have chosen this not to happen. If you want
automatic attachment use “allow”.
6. Xfce - I don’t use it, because I find the keyboard support lacking. I
think what you want has been on the wish list for some time.

1 Like

Thanks for the replies. The help from the community has been over the top amazing I can’t thank you all enough.

Yeah I apologize for bringing some of this up if it’s already been discussed, logged, planned, etc… IIRC I might’ve seen some discussions on some of these issues and in hindsight it would’ve been better for me to post in those other threads separately. Or in the ones fsflover just linked, for sure.

But just to clarify my thoughts:
4. It’s a minor detail, but was just wondering if there’s a config file or something where one could remove the attempts at automatic attachments in the first place (i.e. no point in needlessly attempting connections to dom0, if policy isn’t allow). I created sys-usb using sudo qubesctl state.sls qvm.sys-usb as per the docs, not sure if it’s relevant.
5. In the same docs mentioned above, it mentions a “confirmation dialog” each time the device is connected when policy is set to ask. I do not get this dialog and am wondering if this is normal or if there’s something wrong I should fix.

And sort of combining 4. and 5, I was ideally hoping it would automatically attach and prompt with a confirmation dialog when a device was connected and the ask default_target was specified.

  1. Oh interesting! I wasn’t immediately aware we had other choices. I think I will look into using KDE then, and maybe this will solve 1. for me as well.

my screen is flickering and im trying to see if my CPU is over heating but cant get any CPU temp data from “sensor” in terminal. Qubes 4.1 rc2

A post was merged into an existing topic: Qubes 4.1 rc2 freezing

CPU is over heating after last update from Qubes 4.1 rc3 to Qubes 4.1 rc4 before the fan where very quite
thanks in advance for your help

Might be related: Power Consumption 2-3x after first suspend/resume · Issue #5210 · QubesOS/qubes-issues · GitHub.

Or more probably this: High dom0 cpu usage by [xen-balloon].

@alfonsius Please do not post twice or more about the same problem in different topics.

If found out that, the CPU usage of 100% constantly of one of assigned CPUs is happening only in the Qubes based on the Fedora34 Templates.
Debian11 and Whonix qubes based templates are using the normal resources.
Before with 4.1rc3 the CPU usage was normal, very low.

one solution:
As the issue was present only in the fedora34 qubes.
I resolved it, doing a clean reinstalling of the Fedora34 template,
2nd I did a clone of Fedora34 template; in the clone template I did installed all the need apps for work. In that way I avoided to corrupt the Fedora34 Template with unverified software and/or sources, because Fedora34 is used as template for other qubes as sysnet, etc.