Multiple irritating things

I have the latest stable release installed. There are a number of things that are happening that never happened in the previous version which worked pretty much flawlessly. I have had this installed now for a couple of weeks and use it everyday.

  1. I have the keyboard and mouse enabled from the get go in dom0 so that I can use the keyboard to enter my LUKS pw. It worked flawlessly but now this only works 50% of the time and I have to use the laptop keyboard to input my LUKS pw. If things then boot up ok, by which I mean if sys-usb starts (another irritant) it will then pick up the keyboard and mouse.
  2. If the keyboard is active from the get go in dom0 it frequently then stops working when I have to input my log-in pw. When I input this pw with the laptop keyboard the attached keyboard starts working again when I’ve logged in.
  3. For some reason now qubes opens up in workspace three with a terminal open. No idea why as this isn’t how I left it (not that that should matter).
  4. The version always looks for my wifi to hook up to whereas I want it to pick up my ethernet. I have put incorrect passwords in the wifi security trying to discourage it from this behaviour in which case it continues to nag me for the wifi passwords. I have to connect manually to ethernet.

These are the things that come to mind but there are some others as well. The system is up to date etc. Except for the fact that I have poured a lot of energy into configuring this version I’d go back to the version I was using before as using this a daily driver now with this takes up time for me.

I’d appreciate any insight into what is going on. If I need to collect logs or whatever could instructions on how to do so be provided? Not my area of expertise. The laptop is a Lenovo x-230 16gb i7 with Coreboot/Seabios


Maybe it’s caused by Right-click > Edit Connections... > choose entry > gear icon > "Connect automatically with priority" checkbox.

If all else fails, you could remove the wifi card from sys-net.

  • For some reason now qubes opens up in workspace three with a terminal open. No idea why as this isn’t how I left it (not that that should matter).

Maybe System Tools > Session and Startup > Automatically save session on logout ?

Lenovo x-230 16gb i7 with Coreboot/Seabios

I have the same setup but (un)fortunately I just use the laptop keyboard because it’s pretty good :slight_smile:

1 Like

Thanks for your reply. I have edited the wifi settings, which I never thought of. It had ethernet as ‘default’ but had the other wifis as 'connect automatically by priority, which I have now disabled. This has fixed this problem. Thanks.

No luck with the system tools tip, this box wasn’t ticked and the behaviour persists.

I’ve always just used the laptop and its onboard keyboard but have decided to use qubes now as my daily so I have it hooked up to keyboard and monitor. The keyboard problem is irritating and random. Just like the sys-usb issue where it starts up randomly or if not has to be manually started.

I should never have updated from the previous version which gave me zero issues even though the sys-usb issue is longstanding from what I see. But thanks for fixing that problem. All seems to be good now.

Maybe you need to update the input policy to use the external mouse and keyboard.

Thanks for that. Already done that.

Bear in mind that it had been working perfectly, and sometimes, probably 50-50 it works fine. Its the randomness that is annoying. And I haven’t done anything to the system as I’m not a tinkerer. My needs are pretty minimal so I make minimal changes.

Anything in the logs?

I had that on a few of my Qubes boxes a while back. One of them even had 3 dom0 terminals open. It’s possible that it got merged into an update package.

I was able to fix it my deleting ~/.config/xfce4.

I’m not complaining. I love the terminal. But I did think it was a bit odd :laughing:

Have you considered starting sys-usb later in the boot process?

That might allow you to reliably get your LUKS password and the XFCE login on the USB keyboard, instead of the 50-50 nightmare that you’re currently experiencing…

@renehoj is right. Your qubes-rpc policy settings might need a bit of a tweak :slight_smile:

Thanks for the replies,
I’ll investigate terminal issue although, being a noob here but that folder has a lot of stuff in it. Is it ok to delete it? Does it get re-populated or something. I appreciate the advice but am cautious.

Since I posted the problems I posted have largely resolved except for the terminal issue. I have done nothing except update but now sys-usb starts, the keyboard and mouse work ok so I can’t complain. Its just the terminal.

1 Like