MSI Pro Z690-A WiFi DDR4 with Alder Lake 12900K

I have tried 5.10.112-1.fc32 and 5.16.18-2.fc32

This is the error I get, I checked the log file it’s empty.

error

That’s not the Wi-Fi card:

00:14.3 Network controller [0280]: Intel Corporation Device [8086:7af0] (rev 11)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device [8086:7aa4] (rev 11)

Select 00:14.3 (maybe it’ll be different address for you) device instead of 00:1f.5.

1 Like

It works now :slight_smile:

06:00.0 Ethernet controller: Intel Corporation Ethernet Controller I225-V (rev 03)
00:14.3 Network controller: Intel Corporation Device 7af0 (rev 11)

Added both devices, 5.16 kernel, and updated firmware files.

Device 1f.5 is the PCH Fast SPI Controller used to talk to the BIOS flash.

Can these hardwares work normally on Qubes OS after troubleshooting as described above?

Is sleep/wake normal?
Can WiFi work?
Can you watch 60FPS 4K Youtube video without dropping frames?

@renehoj @tzwcfq

Yes.

Yes.

Yes.

I don’t have 4K display so I can’t tell.

The disadvantages of my MSI MAG Z690 TOMAHAWK WIFI DDR4 motherboard is that it has only one USB controller and USB audio card.

Everything is working for me.

I don’t have 4K display, so I don’t about the quality of 4K resolution, but if I stream 1080p video on 3 monitors at the same time the video starts to have performance issues.

I don’t think you should be surprised if true 4K is going to give you issues.

Did you mean one PS/2 connector?
Can you only use PS/2 keyboard or USB to PS/2 keyboard to input password to login?

Thank you for your reply. We can know 4K may have performance issue too, it’s about 1.34 times of three 1080P by calculating
1.34 = 3840 * 2160 / (1920 * 1080 * 3)

It seems like even the powerful 12900K CPU can’t software render 4K video on Qubes OS well.

My motherboard doesn’t have PS/2 ports so I can only use USB keyboard/mouse.
I’m talking about motherboard having only one PCI USB controller so you can’t have one dedicated USB controller for dom0 to use it for USB keyboard/mouse and have another USB controller for sys-usb to assign USB devices to your qubes.
With one USB controller attached to sys-usb you can assign USB input devices to dom0 but this will have security risks.
Or you can add second PCI USB controller in motherboard and use it.

I just bought a PCI USB controller, they are $20 and the standard via technology VL80x controller work out of the box.

It seems like Qubes OS can only work with PCI USB from your posts although the motherboard has multiple other USB ports. Or you can use non PCI USB but only use PCI USB for USB security consideration? I am not familiar with this because I haven’t run Qubes OS on a desktop.

@renehoj @tzwcfq

They are all connected to the same USB controller.

Qubes 4.1: How to enable a USB keyboard on a separate USB controller

When using a USB keyboard on a system with multiple USB controllers, we recommend that you designate one of them exclusively for the keyboard (and possibly the mouse) and keep other devices connected to the other controller(s). This is often an option on desktop systems, where additional USB controllers can be plugged in as PCIe cards. In this case, the designated controller for input devices should remain in dom0 but be limited to input devices only.

USB qubes | Qubes OS

@miczyg Would it be possible to use the m3deb flashrom to disable Intel Management Engine, or is that section write protected?

I found this post claiming the HAP offset for the Z690 is 0x1de

@renehoj The MSI PRO Z690-A DDR4 does not write-protect any flash regions, so it is possible and you are free to try and set the HAP in the flash descriptor. However, if you don’t have any way to recover in case of some failure I wouldn’t recommend it.

1 Like

I have a WSON test probe and the CH341A programmer, but I don’t know if the programmer can read or write that type of chip.

If I can use that setup to read the chip, I’ll assume write also works and try and set the HAP.

For those who didn’t see yet Phoronix posted review of MSI Pro with Dasharo.

2 Likes

You can disable Intel Management Engine by manually setting the bit a 0x1DE, which should be possible using flashrom with the internal programmer.

Keep in mind, doing this incorrectly can brick the board unless you have an external programmer. I have been able to flash the chip with the ch341a_spi, but it requires a special wson probe to interface with the chip.

I have done it on my system, and it removes mei from lsmod and device reference in /sys/class/mei. It’s been running for some hours now, so I believe it’s stable. The onboard wifi seems to need mei to work, and disabling mei makes the onboard wifi stop working.

I have only tested it with Dasharo, and it might not work with the stock MSI firmware. I’ve seen one person say it makes the stock firmware boot loop, which could be some protection in the msi firmware that detects the modification.

For more info.

Found one major issue with disabling mei, suspending the system no longer works and cash the system to the point it’s unable to boot normally.

The only way to boot the system after suspend is shorting the JBAT1 jumper to reset the CMOS.

1 Like

Dasharo 1.1.0 has been released for the Z690

It’s now possible to disable ME as a firmware feature, among other things.

https://docs.dasharo.com/variants/msi_z690/releases/

v1.1.0 - 2022-11-22

Added

Changed

  • Added new ACPI Platform driver that installs coreboot exposed ACPI tables and all allows native EDK2 ACPI table protocol to install new tables, e.g. Firmware Performance Data Table, BGRT (Boot Logo) of VFCT (AMD GPU ACPI table)
  • Secure Boot is now disabled by default with all keys erased
  • iPXE is now built from source using coreboot-sdk and included externally into UEFI Payload
  • Dasharo setup menu full screen mode support
  • Disabled PCIe ASPM and Clock PM for better PCIe device compatibility
  • Disabled GPIO programming by FSP, coreboot handles the GPIO completely. This additionally fixes a bug in FSP which did not enable SATA DEVSLP properly.
  • Changed Super I/O pin for PECI mode to reflect vendor firmware setting
  • Switched from IOT FSP to public ADL Client FSP
  • Switched to include microcode from public Intel microcode repository
  • Disabled PCIe hotplug
  • Network boot disabled by default, now configurable via menu option

Fixed

Known issues