MSI Pro Z690-A WiFi DDR4 with Alder Lake 12900K

I have not yet had time to install the beta version of the coreboot firmware, but I might try that in the weekend.


Qubes OS seems to be working.

Legacy mode is required to install, without it the installation would just keep looping.

Internal graphics doesn’t work with Legacy mode, I was getting an vbios error, don’t know if this issue can be fixed by updating the firmware.

The onboard Wi-Fi card does work in Qubes OS, this seems to be a driver issue.

Qubes-HCL-Micro_Star_International_Co___Ltd_-MS_7D25-20220519-062815.yml (891 Bytes)

Qubes-HCL-Micro_Star_International_Co___Ltd_-MS_7D25-20220519-062815.cpiogz (12.7 KB)


I also have i9-12900K and official Qubes 4.1 release ISO didn’t work for me when I’ve tried to install in UEFI mode.
But latest Quebs ISO build with kernel-latest worked fine.
Can you check your CPU frequency scaling?
I had an issue with it and wanted to know if others have the same problem:

First run this command in dom0 to see your current governor and if turbo mode is enabled:
xenpm get-cpufreq-para
Check in dom0 your cores frequency in idle mode:
xenpm start 1|grep "Avg freq"
Then assign 16 vcpus (or 24 vcpus if you enabled smt) to one of your VMs and start it. Run some high load process there, for example 7z benchmark:
7z b
Check in dom0 your cores frequency:
xenpm start 1|grep "Avg freq"

1 Like

I’ll run the benchmark when I get back from work, I’ll also try reinstalling the latest build and see if that solves the other issues.

Which kernel are you using, and have you tried the Dasharo firmware?

I don’t want to risk bricking the motherboard by installing the beta version, if someone else already tested it.

1 Like

Kernel-latest 5.17.5 works for me.
With newest kernel-latest 5.17.7 I’m getting graphics artefacts with integrated Intel UHD Graphics 770:

You can get latest Qubes build with kernel 5.17.5 from here:

No I didn’t try it.

1 Like

I did the benchmark and had the same issues with scaling, the P cores are locked at 5GHz but the E cores are able to idle at 800 MHz, and I wasn’t able to get the latest-kernel build til install with UEFI enabled.

Coreboot/Dasharo seems to solve the issue, with coreboot I’m able to install with UEFI enabled. UEFI seems to solve the scaling issue, now all the cores idle at around 1GHz, both P and E. I’ll do some more tests tomorrow, but from my initial tests it seems like coreboot works much better than the stock firmware.

1 Like

HCL report for the Dasharo/Coreboot firmware

Qubes-HCL-Micro_Star_International_Co___Ltd_-PRO_Z690_A_WIFI_DDR4_MS_7D25_-20220519-223036.yml (942 Bytes)
Qubes-HCL-Micro_Star_International_Co___Ltd_-PRO_Z690_A_WIFI_DDR4_MS_7D25_-20220519-223036.cpiogz (9.9 KB)

1 Like

This actually seems to be the normal behavior. At least in Windows it behaves exactly like this.

Can you check if you have all cores at maximum frequency under full load with benchmark?
I had a problem with this and my cores didn’t get to the maximum frequency under full load.

1 Like

Yes, the cores are 5GHz and 3.2GHZ when I stress test.

My guess is that Dasharo is showing the correct values for the ondemand governor, and the other values was for performance. If average is the average of the on time, performance should give the maximum value.

1 Like

@renehoj Congratulations on testing our Dasharo product. Glad to hear it solved the problems with QubesOS installation.

Looking at your HCL report I can see that the memory is clocked at 2133MHz. This is a result of using the standard JEDEC memory profile by Dasharo as it does not suppport selecting an overclocked profile. This is however planned for future extension of the firmware: Memory overclocking support for Dasharo compatible with MSI PRO Z690-A DDR4 · Issue #87 · Dasharo/dasharo-issues · GitHub

@renehoj do you mind if we link your HCL report on our documentation page Memory Compatibility - Dasharo Universe ? If you would be so kind, you may also provide us with more detailed memory information as described on the page.
We would also like to thank you for testing on social media. Is this acceptable for you?

1 Like

@renehoj have you backed up your original firmware image? Dasharo currently does not support Serial Number and UUID migration from vendor firmware. So in case you would need those data, having the original image backup is required.

1 Like

@renehoj you are the first person outside of 3mdeb who publically tested Dasharo on MSI. Thank you for trusting us and being brave trying even in light of potential bricking. We of course tested all procedures many times and are pretty confident that our configuration would work without issues, but you have slightly different memory and we would like to share with community that achievement.

We wonder if it would be ok to share your nick publicly on social media and in that way show our appreciation of your work. More to that we would like to invite you to Dasharo open-source firmware vPub Spring 2022.

P.S. As @miczyg wrote we hope you followed our manual and made backup.

Feel free to use the HCL report, and if I have the time tonight, I’ll make the memory report for you.

I did save a backup of the original firmware dump.

1 Like

The installation was easy, but I couldn’t get it to work from the livecd, and I’m really impressed by how well Dasharo works considering it’s not a full release.

I don’t have a problem with you sharing it on social media, and I’ll try and find the time for the vPub.

I did save the original firmware, in case Dasharo didn’t work.

1 Like

You mean the Dasharo installation method? If you encountered any issues please feel free to describe it in the GitHub issues: Issues · Dasharo/dasharo-issues · GitHub

Well, we have pretty much finished the development. Maybe one more release with small bug fixes and improvements is ahead of us, but that’s all. Everything we will focus on right now will be the feature set like setup options for overclocking, etc.

1 Like

I’d probably never use Qubes forum out of my home. Sorry for the noise, though.

Thank you @renehoj for your HCL report, which is online now!

1 Like

Thank you @renehoj for your HCL report, which is online now!

… does this version have the same limitations as the one with the legacy BIOS or does the integrated gfx and wifi work now?

1 Like
Intel Corporation Device 7af0 (rev 11)

It works but its firmware is missing from linux-firmware (firmware-iwlwifi) package (at least in debian).
I have MAG Z690 TOMAHAWK WIFI DDR4 motherboard and it has the same Wi-Fi card.
Check the output of this command in sys-net:
sudo dmesg | grep iwl
I had errors about missing iwlwifi-so-a0-hr-b0-XX.ucode firmware so I’ve got the the latest XX number supported by my kernel (68 for kernel 5.17.7) from the output of dmesg and then downloaded the missing firmware from here:
Or you can get it from tar signed archive from here:
Then copy this file in /lib/firmware in sys-net template.

1 Like

@Sven please note that MSI uses the MS-7D25 designation for 4 mainboards: The PRO Z690-A WIFI DDR4 and PRO Z690-A DDR4 (with and without a WiFi 6 module) with DDR4 DIMM support, and the PRO Z690-A WIFI and PRO Z690-A, that uses DDR5. These two sets use a different PCB so they should not be taken as variants of the same model. Could you please change “MSI PRO Z690-A (MS-7D25)” to “MSI PRO Z690-A DDR4 (MS-7D25)”? MSI PRO Z690-A (MS-7D25) indicates DDR5 board which has not been reported by @renehoj

Dasharo works well on Qubes 4.1 release in UEFI mode and the igfx. The only problem is WiFi and Ethernet which requires newer kernel drivers and WiFi firmware.


Thank you @miczyg, I’ve made the name change as you suggested.