Mouse Problems in Games

Okay, I’ll try that. Is there any documentation on how to go about doing that? Should I create a usb qube?

You should aready have sys-usb, no further action needed.
Attach your mouse to a usb port of your computer. If you have the standard qubes xfce configuration on the top right there’s an icon (on 4.2 its an orange/grey thing next to the Network manager) that should show you all your usb-devices and you can click on a specific one and attach it to the App/DispVM (qube) you want.

ya, I don’t actually have a sys-usb qube, during the initial installation of qubes, in my ignorance I declined the auto creating of a usb-cube, on qubes documentation, it says I’ll have to manually create one, and I haven’t got around to that yet.

All my devices go to dom0

are you on a desktop or a laptop?
Generally on a laptop having sys-usb is easy because the keyboard uses a p/s2 controller which automatically connects while allowing the filtering of all other attached devices to sys-usb.
I know its a bit more difficult setting up sys-usb on desktop, but there is documentation.

1 Like

I think during qubes installation there are settings that allow you to automatically accept usb-keyboards though of course with the downside that one can theoretically attach a malicious usb through this as it bypasses sys-usb. You can also change these settings in Qubes Global Config.


An easy way is to passthrough the entire USB controller to your HVM.

I successfully used additional USB mouse connected to the qube from USB qube (e.g. sys-usb) to use mouse cursor in the PCem. It works fine as a workaround.
Without additional physical mouse it is impossible to use cursor in Qubes OS due to the relative/absolute position bug that was mentioned above.

1 Like

Okay, Thanks, I’ll try that.


I am on a desktop BTW.

There is a fix to this. If you do not already have a USB qube, create one. Then passthrough the mouse using the usb qube into the qube where your game is running and it will automatically work like a normal pointer game with the “+” does.

Note that when you do this, your mouse will stop working in dom0 and will only work in that qube. To make your mouse work again in dom0 and other qubes, you need to disconnect and reconnect it to the system, usually by physically unplugging it. Let me know if you have any questions.

@Ursidae Okay, Thanks I’ll do that!

I tried this workaround for two different qubes with Minetest and OpenSpades installed via flatpak. Neither would detect the external USB mouse when I attached it directly to the qube.

lsusb command shows that a Lenovo Optical USB Mouse is attached.
xinput does not show the mouse. I am using the debian-12-minimal template so maybe it’s just missing a package or two.

I did basically the same thing, I installed Minetest via flatpak on a fedora-39 template based qube and attached a usb mouse. However at first nothing seemed to happen but it became apparent that the mouse did mount to the qube, just without a visible pointer. I can play games like minetest, but the mouse is “invisible” the whole time which is really annoying, and makes game play very difficult.

I was able to resolve the issue with OpenSpades by re-creating the Qube using a standard debian-12 template, then attaching the external USB mouse direct to it as suggested earlier in the thread. So the issue in my case was with the debian-12-minimal template lacking the required mouse Xorg support.

I’ll try this for minetest too and let you know if it resolves.

UPDATE: external USB mouse is behaving correctly after rebuilding Minetest Qube with debian-12 standard template.

1 Like

So does your mouse pointer actually show up? Because in both the Debian and fedora qubes I have, the mouse “works” like it should after mounting it, but its not actually visible, for example:

You can see where the mouse is by the highlighted box it’s selecting, but you don’t see the mouse pointer itself. I understand this is a commen issue I just don’t know how to fix it.

Confirmed that the pointer does not show up in Minetest on my end either. The workaround only fixes the squirrelly/spinning mouse problem when playing the game.

1 Like

Has anyone found a fix to the “no mouse pointer” problem? I ran into the same problem. Blender works fine (HVM with a RTX 4060 via passthrough), but I can’t use the value sliders, as these seem to “grab” the mouse, which doesn’t work / isn’t allowed in Qubes. So I attached a second mouse and passed the USB-device to the AppVM. Works as intended, but is unusable, as there is no mouse pointer. Same in Gimp or even the terminal itself. Everything works, but no mouse pointer is rendered.

Any help would be greatly appreciated!