Mouse Problems in Games

So, on certain games like Minetest, and I’ve heard Minecraft, the mouse does not seem to interface with the game correctly. For example, on Minetest, a sandbox game similar to Minecraft, when the mouse pointer would normally be replaced by a “+” , instead the mouse pointer remains alongside the “+” causing the game to be very jerky, laggy, unresponsive, and nearly impossible to play. other than the mouse, everything works fine. do I need to mount the mouse to the app vm separately somehow? Will the upcoming Qubes update fix the problem? should I wait until then?
I’m not new to linux or Qubes, however, I’m used to operating in the GUI mostly, and though I’m learning how to operate via the command line, my proficiency has much to be desired, so if you could explain it as simple as possible, that would be much appreciated.

1 Like
2 Likes

So there’s no known solution?

Also, I’m using Qubes OS Version 4.1, not sure that matters though.

I think passing a dedicated mouse to your target qube should help.

Okay, I’ll try that. Is there any documentation on how to go about doing that? Should I create a usb qube?

You should aready have sys-usb, no further action needed.
Attach your mouse to a usb port of your computer. If you have the standard qubes xfce configuration on the top right there’s an icon (on 4.2 its an orange/grey thing next to the Network manager) that should show you all your usb-devices and you can click on a specific one and attach it to the App/DispVM (qube) you want.

ya, I don’t actually have a sys-usb qube, during the initial installation of qubes, in my ignorance I declined the auto creating of a usb-cube, on qubes documentation, it says I’ll have to manually create one, and I haven’t got around to that yet.

All my devices go to dom0

are you on a desktop or a laptop?
Generally on a laptop having sys-usb is easy because the keyboard uses a p/s2 controller which automatically connects while allowing the filtering of all other attached devices to sys-usb.
I know its a bit more difficult setting up sys-usb on desktop, but there is documentation.

1 Like

I think during qubes installation there are settings that allow you to automatically accept usb-keyboards though of course with the downside that one can theoretically attach a malicious usb through this as it bypasses sys-usb. You can also change these settings in Qubes Global Config.

2 Likes

An easy way is to passthrough the entire USB controller to your HVM.

I successfully used additional USB mouse connected to the qube from USB qube (e.g. sys-usb) to use mouse cursor in the PCem. It works fine as a workaround.
Without additional physical mouse it is impossible to use cursor in Qubes OS due to the relative/absolute position bug that was mentioned above.

1 Like

Okay, Thanks, I’ll try that.

Thanks!

I am on a desktop BTW.

There is a fix to this. If you do not already have a USB qube, create one. Then passthrough the mouse using the usb qube into the qube where your game is running and it will automatically work like a normal pointer game with the “+” does.

Note that when you do this, your mouse will stop working in dom0 and will only work in that qube. To make your mouse work again in dom0 and other qubes, you need to disconnect and reconnect it to the system, usually by physically unplugging it. Let me know if you have any questions.

@Ursidae Okay, Thanks I’ll do that!