Little issue with Monero split wallet and /var/run/qubes-service

I’ve set up a split wallet for Monero using the guide:

Had to redo it recently after my qube proved corrupt. I’m having an issue I can’t figure out. See the file:


and the line in it:


My service doesn’t start automatically because /var/run/qubes-service/monerod-mainnet is misspelled. I can rename it and it works fine. But I’ve gone through the guide a few times and can’t figure out how that file is created so I can change the name.

Not sure if my issue is Qubes specific, but hoping someone can provide an answer easily.

There must have been a typo during this step:

[user@dom0 ~]$ qvm-service --enable monerod-ws monerod-mainnet

Just rerun that.

The misspelled one can be removed with qvm-service --unset ... or in the Qube SettingsServices GUI.

It will take effect when the qube is restarted.

1 Like

Thank You!

I thought it had to do with enabling the service, but only redid it in the monerod-ws (with systemctl). Somehow I missed the dom0 service enable. I used the Qube Settings GUI to remove the misspelled one. Then reran the command in dom0 you posted.

Now it’s working as it should.